CS1000: BUG2104 Wrong Cabinet number : 3 on MGC when issuing switch CPU command (LD 135 .SCPU) on Call Server
Details
CS1000E
Release 7.65 with Service Pack 4
MGC
SETUP AND ACTIONS PERFORMED TO CAUSE THE PROBLEM:
Setup: CS1000 HA system.
Actions:
1. Issue "scpu" in LD135 on the CS
2. Check MGC rpt logs.
EXPECTED RESULTS:
1. Graceful switchover completes successfully.
2. No BUGs in MGC rpt logs.
ACTUAL RESULTS:
1. Graceful Switchover completes successfully.
2. BUG2104 is observed in MGC logs:
RPT log example from MGC:-
13/03/2014 16:58:35 BUG2104 Wrong Cabinet number : 3
13/03/2014 16:58:45 LOG0004 tRUDPSS: Forwarding for connect Id = 0x84d1e238,
error of type = 6 (connection lost).
13/03/2014 16:58:45 LOG0003 tRUDPSS: pbxErrorCallBack on link 2, reset link(s)
13/03/2014 17:00:00 LOG0006 PBXResetLink: PBX UDP link established for link 2
Problem Clarification
BUG2104 Wrong Cabinet number : 3 on MGC when issuing switch CPU command (LD 135 .SCPU) on Call Server.
Cause
Software Bug .The issue is reproducible in Avaya lab and happens even if cores and MGC are located
in the same cabinet. So, issue is not caused by the network
conditions.
During debugging I found that the issue happens because of illegal HB ping message
received by MGC. Decoded IP address points to the inactive CS side. However, MGC
shouldn’t receive HB messages from the inactive side and as result, MGC reports
BUG2104. Also, after printing BUG2104, PBX link is successfully established with the
active CS.
It was found a place in the code, where the inactive CS enables “eth” interface to send
gratuitous ARP message before the reboot. suspect during this activity inactive CS
send HB ping message to the MGC.
Solution
Install CS PEP MPLR33207
Details
CS1000E
Release 7.65 with Service Pack 4
MGC
SETUP AND ACTIONS PERFORMED TO CAUSE THE PROBLEM:
Setup: CS1000 HA system.
Actions:
1. Issue "scpu" in LD135 on the CS
2. Check MGC rpt logs.
EXPECTED RESULTS:
1. Graceful switchover completes successfully.
2. No BUGs in MGC rpt logs.
ACTUAL RESULTS:
1. Graceful Switchover completes successfully.
2. BUG2104 is observed in MGC logs:
RPT log example from MGC:-
13/03/2014 16:58:35 BUG2104 Wrong Cabinet number : 3
13/03/2014 16:58:45 LOG0004 tRUDPSS: Forwarding for connect Id = 0x84d1e238,
error of type = 6 (connection lost).
13/03/2014 16:58:45 LOG0003 tRUDPSS: pbxErrorCallBack on link 2, reset link(s)
13/03/2014 17:00:00 LOG0006 PBXResetLink: PBX UDP link established for link 2
Problem Clarification
BUG2104 Wrong Cabinet number : 3 on MGC when issuing switch CPU command (LD 135 .SCPU) on Call Server.
Cause
Software Bug .The issue is reproducible in Avaya lab and happens even if cores and MGC are located
in the same cabinet. So, issue is not caused by the network
conditions.
During debugging I found that the issue happens because of illegal HB ping message
received by MGC. Decoded IP address points to the inactive CS side. However, MGC
shouldn’t receive HB messages from the inactive side and as result, MGC reports
BUG2104. Also, after printing BUG2104, PBX link is successfully established with the
active CS.
It was found a place in the code, where the inactive CS enables “eth” interface to send
gratuitous ARP message before the reboot. suspect during this activity inactive CS
send HB ping message to the MGC.
Solution
Install CS PEP MPLR33207