Can't receive faxes from Cisco VoIP PBXs

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  • araiza
    Member
    • Sep 2014
    • 4

    Can't receive faxes from Cisco VoIP PBXs

    Hello, I have an Avaya CM 6.3 and implemented SIP this past summer. We have a Biscom fax server 6.3 for inbound faxes only. We started receiving complaints of incomplete faxes that were being cut-off, example - receiving only 1-2 pages of a 10 page document with the last page always cut off. I changed my ip-codec-set page 2 from FAX Mode OFF to FAX Mode t.38-standard, redundancy 0, and ECM Yes. Everything started working, complete 20 page documents...life was good. After the change, we started receiving a few complaints from sites not being able to fax to our CM switch at all from Cisco PBXs whether small Brother faxes or Multi-Functional Device faxes.

    When we change the FAX Mode setting back to OFF, the faxes start coming in from Cisco PBXs but the other sites having incomplete faxing issues resumed. So for now, no Cisco PBX sites are able to fax at all to our Avaya CM. When the Cisco PBX sites route their outbound faxes through their traditional TDM trunks, the faxes are received fine. Our company is moving from a TDM to SIP environment across the country.

    Current settings page 1:
    G.711MU n 2 20

    page 2:
    Allow Direct-IP Multimedia? y
    Max Call Rate for Priority Direct-IP Multimedia: 256
    Max Call rate for Priority Direct-IP Multimedia: 256

    Does anyone know of any settings to accommodate inbound faxing from a Cisco PBX?

    Thank you - pulling my hair out trying to figure this out
  • sunilkumarv
    Guru
    .
    • Mar 2010
    • 124

    #2
    You need to Turn off the modem on the codec and use T.38 for fax, you can also try with pass-through.

    Since you will be using SIP trunk's , you can create a new SIP signalling and trunk group to your cisco switch and use a different Network-region and codec set with working config for your Cisco device.

    Regards
    Sunil
    Regards,
    Sunil

    AVAYA| Voice: US:- +1 720 444 5271, India: +91 80 6715 3277 | Email:[email protected]|

    Comment

    • araiza
      Member
      • Sep 2014
      • 4

      #3
      Thank you for your reply Sunil

      I made my codec change to pass-through (modem was turned off already) and faxes from Cisco devices came in fine, but others were coming with half pages as before. So I changed the setting back to T.38-Standard.

      I will do your suggesting in creating a new SIP signaling and trunk group with a new Network-region and codec set just for the inbound faxes from Cisco PBXs.

      Wish me luck, I will let you know how it goes. It's a challenge to accommodate every PBX in this SIP environment.

      Thanks again Sunil - I can see a small light at the end of the tunnel

      Comment

      • araiza
        Member
        • Sep 2014
        • 4

        #4
        Looking at other options...

        Hello Sunil,

        I received a response from Avaya. The Avaya CM should be set at T.38 for the IP-Codec-Set. The other issues are with the Cisco PBX. I will test with other sites after they have made the appropriate changes to their Cisco PBX and let you know the results.

        Thank you-

        --J.R.

        PROBLEM CLARIFICATION
        Fax over Internet Protocol (FOIP) call between Avaya and Cisco gateway does connect, fax machine plays fax tone and then drops.
        CAUSE
        Avaya only supports T.38 protocol with Cisco. This is failing due to incorrect setting and configuration issues on CM side, Cisco side and also on Fax machines.
        SOLUTION
        · On CM side, change mode on IP-CODEC-SET form to T.38
        · The Cisco gateway needed to be set for MGCP and not SCCP on both the VG224 gateway and the Call Manager VG224 config
        · On newer SuperG3/ECM type Fax machines make sure the ECM turned on

        A - On CM side, change mode on IP-CODEC-SET form to T.38
        1. Log in to SAT.
        2. Change mode on IP-CODEC-SET (which is used for this call) form to T.38 and save changes.
        display ip-codec-set 1 Page 2 of 2

        IP Codec Set

        Allow Direct-IP Multimedia? n

        Mode Redundancy

        FAX pass-through 1 <---------- Change this to T.38.

        Modem relay 1

        TDD/TTY US 3

        Clear-channel n 0

        B- Ask the user to check and set the Cisco side. The Cisco gateway needs to be set for MGCP and not SCCP on both the VG224 gateway and the Call Manager VG224 config
        C - Ask user to check and make sure that on newer SuperG3/ECM type Fax machines the ECM turned on
        Make FOIP calls, it should work now.
        LEGACY ID
        KB01076590

        Comment

        • sunilkumarv
          Guru
          .
          • Mar 2010
          • 124

          #5
          yes, we recommend to use T.38 as a standard protocol for fax, if the solution does not work, you can always use a new SIG/trunk group as we know it works with different configuration.
          Regards,
          Sunil

          AVAYA| Voice: US:- +1 720 444 5271, India: +91 80 6715 3277 | Email:[email protected]|

          Comment

          • araiza
            Member
            • Sep 2014
            • 4

            #6
            It's working now!

            Dear Sunil - So the initial problem was are gateways are SCCP, I change one to MGCP but that failed too, opened TAC case, problem was the gateway was sending out T.38, our voice gateways were trying to transcode but we did not have pass through configured on our voice gateways. Faxing seems to be working now from Cisco to Avaya PBXs.

            Thank you for all your support!

            --J.R. Araiza

            Comment

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