Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Contact Center Applications (http://support.avaya.com/forums/forumdisplay.php?f=3)
-   -   Can't obtain correct value for ANI in AVP using cti connector (http://support.avaya.com/forums/showthread.php?t=3289)

dfrade 04-22-2013 09:18 AM

Can't obtain correct value for ANI in AVP using cti connector
 
Hi all,

We have a problem using cti connector in dialog designer application with VoicePortal 5.1. The application only writes to trace.log the value of :
--------------------
session dnis
session ani
cticallinfo: ani
cticallinfo dnis
--------------------

Whole example of the call:
customer call to ddi, and is routed to VDN and then to agent.
Agent makes a consultation call to another second VDN and finish the transfer.

If no agents answer in the second VDN , call is routed to Voice Portal VDN, and then to Voice Portal Application.

I recieve "cticallinfo: ani" like this: "T2501#1" instead of real customer ANI. I guess this is the Dynamic Device ID, but i don't know why it is populating this, instead of real customer ANI.
¿What is happening?, ¿Does anybody know how to fix this behaviour?

wawior 04-22-2013 11:16 PM

Hello
 
It can happen if Caller has CLIR enabled.

Regards
Michał

dfrade 04-22-2013 11:55 PM

Could you explain me how to do it?

I guess is in system parameters features, in
CPN/ANI/ICLID Replacement for Restricted Calls:

CPN/ANI/ICLID Replacement for Unavailable Calls:
¿is it true?

What i should write there?

Thank you very much

wawior 04-24-2013 02:42 AM

dfrade
 
I mean,

that Caller Mobile Phone can have CLIR enable - so operator would not allow to present his number.

dfrade 04-24-2013 02:46 AM

Now I understand wat you mean with CLIR.

No, is not our case, customer and test that we have done, were without CLIR enabled...

It must be another thing.

In any case, thanks for your answer.

dfrade 05-07-2013 02:08 AM

Anybody knows how to help me?

shvalbe 05-13-2013 02:38 AM

what is the CM version are you using?

dfrade 05-13-2013 03:18 AM

Operating system: Linux 2.6.18-128.AV14xen i686 i686
Built: Sep 24 00:54 2010

Contains: 00.1.510.1
CM Reports as: R016x.00.1.510.1
CM Release String: vcm-016-00.1.510.1

UPDATES:
Update ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
00.1.510.1-19916 activated cold Combo of 19594 19912 19915

dfrade 06-03-2013 03:51 AM

update
 
Does anybody know how to help me with this?

Any response will be appreciated

tothm 02-17-2014 07:24 AM

same problem here and the # in the number it blocks the script
 
HI We have the same problem with a cutomer using AVP.

Having the unknown ANI replacement not working out in this case (set in cust fea page 9 and trunk page 3 )

Do you already have a solution for this probelm in the meantime ?

Marcell


All times are GMT -7. The time now is 08:28 AM.