IC 7.3.x: TS goes down with error message "Agent event are not enabled" after 2 minutes


Doc ID    SOLN158593
Version:    5.0
Status:    Published
Published date:    08 May 2020
Created Date:    05 Jan 2012
Author:   
chengdongzhao
 

Details

IC 7.3.x ,AES 6.2.x, ACM 6.2 : Windows Environment

 

Problem Clarification

ASAI Proprietary feature are enabled in CM, but IC TS server starts with error message "Agent events are not enabled" and goes down after exactly two minutes as shown :

Snippet of TS LOG file received :
 
@20131118 13:02:48.106 <LicenseOps-DeepDebug:TS:10.250.21.150@17187(5552:3372) : Successfully requested feature license <TSDefinitySvrs> <Handle:2976; Expiry:1387371768>.> [..\impl\LicenseOps.cpp@689]
![2013-11-18 13:02:48.150] <7032:pbxLink>
      saoid     [6] [FROM Switch ACK ] [C_VQ_CONF Response Ack Value Query]
 
![2013-11-18 13:02:48.150] <7032:pbxLink> Reported PBX Software Version: R016x.02.0.823.0 Field Version: R16
![2013-11-18 13:02:48.349] <7032:pbxLink>
      saoid     [8] [FROM Switch NACK] [C_RF_CONF Response Request Feature]
      ASAI error[7]:[being Monitored by another]
 
@20131118 13:02:48.356 <Alarm:TS.CpbxASAI> [.\tools\common.c@3198]
@20131118 13:02:48.386 <RequestOut> [.\tools\vesp_edr.c@361]
Session=528a0ff7000100000afa159623430002
Request=528a0ff8000400000afa159623430002
Object=52567273000000000afa1596232b0002
Text: [Alarm.Alarm({0,"TS.CpbxASAI",{0,4,{"object","527f1eff000000000afa159623430002"},{"owner","527f1eff000000000afa159623430002"},{"priority","INFO"},{"descript","Agent events are not enabled"}}})]
CTX={0,4,{"group","Voice1"},{"usrsec","0"},{"name","527f1eff000000000afa159623430002"},{"cobject","527f1eff000000000afa159623430002"}}
![2013-11-18 13:02:48.828] <7956:threadMonitorLinkStart> Thread terminated
![2013-11-18 13:03:08.122] <4456:threadSendHeartBeat>
      saoid     [10] [=TO= Switch REQ.] [C_HB_REQ HeartBeat]
 ![2013-11-18 13:03:08.127] <7032:pbxLink>
      saoid     [10] [FROM Switch ACK ] [C_HB_CONF Response HeartBeat]
 ![2013-11-18 13:03:28.140] <4456:threadSendHeartBeat>
      saoid     [12] [=TO= Switch REQ.] [C_HB_REQ HeartBeat]
 ![2013-11-18 13:03:28.149] <7032:pbxLink>
      saoid     [12] [FROM Switch ACK ] [C_HB_CONF Response HeartBeat]
@20131118 13:03:47.017 <TS iver:7.3.1 (Build 9) - 2013.06.28 22:21 -  (DEFINITY)> [.\ctsserver.cpp@2228]
![2013-11-18 13:03:48.171] <4456:threadSendHeartBeat>
      saoid     [14] [=TO= Switch REQ.] [C_HB_REQ HeartBeat]
 ![2013-11-18 13:03:48.222] <7032:pbxLink>
      saoid     [14] [FROM Switch ACK ] [C_HB_CONF Response HeartBeat]
 ![2013-11-18 13:04:08.230] <4456:threadSendHeartBeat>
      saoid     [16] [=TO= Switch REQ.] [C_HB_REQ HeartBeat]
 ![2013-11-18 13:04:08.243] <7032:pbxLink>
      saoid     [16] [FROM Switch ACK ] [C_HB_CONF Response HeartBeat]
 ![2013-11-18 13:04:28.246] <4456:threadSendHeartBeat>
      saoid     [18] [=TO= Switch REQ.] [C_HB_REQ HeartBeat]
 ![2013-11-18 13:04:28.265] <7032:pbxLink>
      saoid     [18] [FROM Switch ACK ] [C_HB_CONF Response HeartBeat]
@20131118 13:04:47.008 <TS iver:7.3.1 (Build 9) - 2013.06.28 22:21 -  (DEFINITY)> [.\ctsserver.cpp@2228]
![2013-11-18 13:04:48.107] <7032:pbxLink> Receive from switch failed error [-12/0]
![2013-11-18 13:04:48.107] <7032:CapiPBX> started sending linkdown events to all monitoring parties
![2013-11-18 13:04:48.107] <7032:CapiPBX> linkdown events sent to all monitoring parties
![2013-11-18 13:04:48.108] <4280:CapiPBX> delaying the server abort for graceful shutdown
![2013-11-18 13:04:48.111] <7032:CapiPBX> Requested ASAI close
![2013-11-18 13:04:48.112] <7032:CapiPBX> ASAI close completed
![2013-11-18 13:04:48.112] <7032:CapiPBX>

 

Cause

Important to know : in AES CVLAN with proprietary link enabled, it mandatory requires ASAI Agent Event feature enabled otherwise the link will bounce every 2 minutes. This feature is at CM side ! 

So this is very important to fix the Agent Events here… to get a stable CVLAN link with AIC TS server.

Solution

The things that need to be done to have Agent Events enabled are :

CM
 

CM - System Parameters - Customer Options - Computer Telephony Adjunct Links - set to ‘y’

     ASAI Core and ASAI Plus do not matter

CM - System Parameters - Customer Options - Agent States - set to ‘y’

   - IC also needs Increased Adjunct Route Capacity, but that doesn't affect agent events.

CM - System Parameters - Features - Expert Agent Selection - set to ‘y’

and also set to ‘y’ in ‘System Customer Features’ page as well.

CM - System Parameters - Features - Copy ASAI UUI During Conference Transfer - set to ‘y’

CM - System Parameters - Features - Create Universal Call ID (UCID) - set to ‘y’ and Network node ID.

CM  - a CTI link with type ADJ-IP (none of the other type settings will work for IC+AES+AgentEvents) 

 
AES

On AES License, Interaction Center Proprietary Link RTU, 1 per IC Telephony server.
On AES License, CVLAN RTU
On AES, a CVLAN CTI link with Proprietary checked, Version set to 4.
  a.  You should also have Heartbeat not checked, but that will cause the link to bounce, it doesn't effect agent events.
 
 
Note that in recent ACM versions the ASAI Agent State option is not displayed in Page 9 anymore ….it seems it was renamed as follows :
 
ASAI PROPRIETARY FEATURES
       Proprietary? y
 
The missing feature here was the EAS on the ACM System Features page.

display system-parameters features                              Page  11 of  20

                       FEATURE-RELATED SYSTEM PARAMETERS

CALL CENTER SYSTEM PARAMETERS  EAS
 

           Expert Agent Selection (EAS) Enabled? n    >> it must be set to YES

Once enabled, the Alarm info “Agent Events are Enabled “ is getting displayed on TS Voice1 startup  which is much better and getting the CVLAN link stable between ACM and AIC TS.
 

Legacy ID

KB01120483

Additional Relevant Phrases

If customer want to use CVLAN link you have to purchase the general purpose CVLAN link license. This license will switch the ASAI Core / ASAI Plus options to YES on Communication Manager side as well.

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy