CS1000: Release 6.0, 7.0 and 7.5 /var directory is 100% full (warning message /var reached 85%)


Doc ID    SOLN204599
Version:    7.0
Status:    Published
Published date:    03 Feb 2016
Created Date:    21 Jun 2012
Author:   
Pankaj Motwani
 

Details

SS : /var partition is full
/var is 100% full

 

Problem Clarification

/var is 100% full. warning messages may be seen, such as: " /var has reached 85%"

To confirm, use the DF -h command to list the usage of the various partitions.

Cause

Log files and  SP/SU patch files not in use.

 

We have only 7 GB allocated for /var directory. In which all the logs files, applications installed the NRS logs, TPS logs comes. Even when a new phone gets registered space is taken from /var partition.
 

Solution

Remove the log files from /var and also remove any unused patches  and /var usage will fall to a usable level.

For R7.5 the current SP should be installed which includes a script to help keep the logfiles trimmed.

 The current

How to free up disk space for Service Pack installation.
If during SP installation you get an error message like “There is no enough disk space on “/var” partition”, you should follow these steps to free up additional disk space.
If you want to free up disk space on “/admin” partition:
Remove *.nai file(s) from the system. Log in to UCM and go to Software Deployment Software Loads. Select *.nai load(s) and click ‘Delete’ button. ->
If you want to free up disk space on “/var” partition:
1.                   Remove patching content.
Log in to UCM and go to Patches -> Patches and select one of the three targets:
Service Packs & Deplists – if you want to remove Service Packs/Deplists;
Patches – if you want to remove patches;
Loadware – if you want to remove Loadware file(s);
Select unnecessary Patch Content and click ‘Delete’ button.
2.                   Clean up backup archives.
Log in to UCM and go to Software Deployment -> Backups page, select backup(s), and click ‘Delete’ button. You can save your backup files on remote servers (SFTP backup).
3.                   Remove any files from “/var/opt/nortel/patch/sp”. Login as nortel/admin2 on CS1000 and invoke:
cd /var/opt/nortel/patch/sp
rm *
4.                   Empty the /var/opt/nortel/base/RecoveryCache folder. Login as nortel/admin2 on CS1000 and invoke:
cd /var/opt/nortel/base/RecoveryCache
rm *
5.                   To free up temporary disk space consumed by patching operations.
It is necessary to clear completed activities in Patching Manager. All ongoing operations on targets can be viewed in the "In Progress" tab. Options are given to proceed with patching activation once patching impact assessment is completed (in manual mode) or to clear completed operations. Both should be done promptly to free up space and allow other patching of any other targets to proceed.
6.                   Clean up old logs from “/var/log/nortel/old_logs/”. Login as nortel/admin2 user on CS1000 and invoke:
cd /var/log/nortel/old_logs
rm *
7.                   Clean up two Jboss log folders on the Primary UCM:
 “/var/opt/nortel/Jboss-Quantum/conf/quantum-config/securityserver/stats/” and “/var/opt/nortel/Jboss-Quantum/conf/quantum-config/securityserver/log/”
Login as nortel/admin2 user on CS1000 and invoke:
[nortel@kwei]$ cd /var/opt/nortel/Jboss-Quantum/conf/quantum-config/securityserver/stats/
[nortel@kwei stats]$ ll
total 60104
-rw-r--r-- 1 nortel nortel 5735784 Jul 9 09:04 amMasterSessionTableStats
-rw-r--r-- 1 nortel nortel 39464614 Jul 9 09:04 amPolicyStats
-rw-r--r-- 1 nortel nortel 16263642 Jul 9 09:04 idRepoCacheStat
[nortel@kwei stats]$ touch tempstat
[nortel@kwei stats]$ chmod 644 tempstat
[nortel@kwei stats]$ cp tempstat amMasterSessionTableStats
[nortel@kwei stats]$ cp tempstat amPolicyStats
[nortel@kwei stats]$ cp tempstat idRepoCacheStat
[nortel@kwei stats]$ ll
total 0
-rw-r--r-- 1 nortel nortel 0 Jul 9 09:08 amMasterSessionTableStats
-rw-r--r-- 1 nortel nortel 0 Jul 9 09:08 amPolicyStats
-rw-r--r-- 1 nortel nortel 0 Jul 9 09:08 idRepoCacheStat
-rw-r--r-- 1 nortel nortel 0 Jul 9 09:05 tempstat
[nortel@kwei stats]$ cd /var/opt/nortel/Jboss-Quantum/conf/quantum-config/securityserver/log/
[nortel@kwei log]$ ll
total 12800
-rw-r--r-- 1 nortel nortel 99825 Jul 9 08:51 amAuthentication.access
-rw-r--r-- 1 nortel nortel 130734 Jul 9 09:10 amAuthentication.error
-rw-r--r-- 1 nortel nortel 11149768 Jul 9 08:51 amPolicy.access
-rw-r--r-- 1 nortel nortel 1302741 Jul 9 08:50 amPolicyDelegation.access
-rw-r--r-- 1 nortel nortel 7738 Jul 9 08:49 amPolicy.error
-rw-r--r-- 1 nortel nortel 181853 Jul 9 08:51 amSSO.access
-rw-r--r-- 1 nortel nortel 181524 Jul 9 08:51 ecm-administration.access
[nortel@kwei log]$ touch templog
[nortel@kwei stats]$ chmod 644 templog
[nortel@kwei log]$ cp templog amAuthentication.access
[nortel@kwei log]$ cp templog amAuthentication.error
[nortel@kwei log]$ cp templog amPolicy.access
[nortel@kwei log]$ cp templog amPolicyDelegation.access
[nortel@kwei log]$ cp templog amPolicy.error
[nortel@kwei log]$ cp templog amSSO.access
[nortel@kwei log]$ cp templog ecm-administration.access
 
8.                   Clean up SPS logs (if NRS applications are deployed). Login as nortel/admin2 user on CS1000 and invoke:
cd /var/opt/nortel/sps/LOG/old_logs/
rm *
9.                   Uninstall previously applied patches.

delete the files as mentioned above. if still warning is seen then  the only way we have is to increase the size of hard disk or change the hardware to CPDC

 

You may also find large log old files in the following directory:

/var/opt/nortel/Jboss-Quantum/conf/quantum-config/old_logs


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