96xx IP phones. Disable the hook switch via 46xxsettings. To prevent agents accidentally going off hook -HEADSYS


Doc ID    SOLN209438
Version:    2.0
Status:    Published
Published date:    20 Jun 2017
Created Date:    31 Aug 2012
Author:   
Joanna Juarez
 

Details

96xx IP phones. how to disable the hook switch via the 46xxsettings file

The enhancement listed in the release note references disabling the hook switch on
the handset. That is what they are trying to accomplish.
The agents are taping the handsets to their phones to avoid the handset going off-hook.

Extract from OLD Release Notes:
"This set up tells me there was intended to use the callcenter agent in auto-answer
mode. Auto-answer mode requires that phone always remains in off-hook status. Once
phone goes on-hook, agent is kicked out from skill. This is working as designed
since day one."

The release notes state ""Administrator can disable the hook switch via the settings file to prevent agents accidentally going off hook and then on hook with the handset."96xx IP phones. hook switch setting in 46xxsettings file.
In all readme files starting with the release of H.323 firmware 6.2, a new feature is documented stating that an administrator can now disable the hook switch in a call center environment to prevent the agent from getting logged out when the handset is removed.
However, there is nothing that we can find in any documentation or in the latest 46xxsettings.txt file that tells us how to disable the hook switch.
CALLCNTRSTAT and HEADSYS parameters with customer, at 3 sites and they had no affect on the problem we are having.
Regardless of the settings on those parameters, taking the handset off-hook and then back on-hook logs the agent out.
The enhancement listed in the release note references disabling the hook switch on the handset. That is what we are trying to accomplish.
The agents are taping the handsets to their phones to avoid the handset going off-hook.

Auto-answer mode requires that phone always remains in off-hook status. Once phone goes on-hook, agent is kicked out from skill. This is working as designed since day one.
So this is the reason cust wants to prevent agents going on-hook.

Problem Clarification

96xx IP phones. how to disable the hook switch via the 46xxsettings file

concerning the Enhancement listed
(http://support.avaya.com/downloads/download-details.action?contentId=C20126495150303
0_4&productId=P0553), under the heading “Enhancements with Avaya one-X® Deskphone
H.323 Release 6.2:” “Contact Center features” listed that reads:
"Administrator can disable the hook switch via the settings file to prevent agents
accidentally going off hook and then on hook with the handset."

Cause

Customer is using 9611 phone with headset in callcenters suing auto-answer mode and HEADSYS set to 1. Handset is off the cradle (due to mess with HEADSYS in 6.2 I guess). Cust observed that when agents place the handset back to cradle, the agent gets kicked out from ACD and cannot take calls from queue. Cust is requesting clarification, on which exact setting is being referred in 96x1 H323 6.200 release notes, as well as in all 6.2 issues of 96x1 H323 Admin Guide as: Administrator can disable the hook switch via the settings file to prevent agents accidentally going off hook and then on hook with the handset. This had resulted in them disconnecting the active call and being logged out. Cust believes that this setting will fix their problem.

Solution

HEADSYS is clear and understood (not equal to accepted – sic!).
They are looking for clarification on the the hook control by an unknown setting referenced in our 6.2 doc

There is no such settings – the hook status cannot be controlled from software. Otherwise for 9641 phone we would have no faceplate introduced for callcenter customers. The faceplate is there for the same purpose: to hide/cover the hook and this way agents cannot access it.

######
We could reproduce the issue, and R6.0 readme (and Admin Guide for R6.2 SP2) was not correct.
Now, we have checked the 6.2 SP1 and 6.2 SP2 readme files and this statement has been removed. It only appears in the 6.2 GA readme.

So, there is no way to disable the switch hook state via the settings file.

We have confirmed that there is no parameter in the settings file to control the switch hook status.

Additional Relevant Phrases

HEADSYS specifies whether the telephone will go on-hook if the headset is active

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