CTI receiving incorrect DNIS from CM after a transferred call in the Delivered event. Established event is OK


Doc ID    SOLN209765
Version:    2.0
Status:    Published
Published date:    14 Sep 2017
Created Date:    06 Sep 2012
Author:   
Ronaldo Vallino
 

Details

ANY GA RELEASE - COMMUNICATION MANAGER

INTEGRATION WITH AACC, AC (may apply to other third-party applications)

Problem Clarification

Any internal station is calling to an external number #YYYY-YYYY and sending the Calling Party Number #XXXX-XXXX. After that, call is transferred to a VDN #ZZZZ.

CTI is receiving YYYY-YYYY as DNIS information. Delivered event shows YYYY-YYYY as DNIS information but Established event shows ZZZZ

Problem is that CTI considers Delivered event to get the DNIS information but They need to receive ZZZZ.

Cause

There are two calls involved. First is the station calling to external number and then, the same station is transferring to an internal VDN. When this user wait any answer before transferring (Consulting transfer) there is no problem and CTI receives correct DNIS info.

When the station does a blind transfer (doesn't wait any answer before transfer) CM mergers both calls and the first one is considered to provide information to DISPLAY and CTI links.

Solution

VDN has an option "to fix"the VDN number as DNIS info sent to CTI (Not on DISPLAY).

Go to the second page of VDN form and change the filed below to "all" . You must set "allow VDN override" to YES on the first page to enable it.

              Display VDN for Route-To DAC*? n
            VDN Override for ASAI Messages*: all     <<<<<<<<<<<<<<<
 

With this feature enabled CTI will receive the VDN number as DNIS for calls to this VDN. (Consider the VDN override options for calls VDN /VDN)


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