AIC: New EDUID created when call is transferred from one TS to another using queue to skill.


Doc ID    SOLN213710
Version:    2.0
Status:    Published
Published date:    17 Jan 2014
Created Date:    06 Nov 2012
Author:   
Roshan Varghese Jacob
 

Details

To understand the cause of new EDUID's being created, let us first understand the scenarios tested. This test involves a CM, an AES (we can also use two AES, it would not make any difference), two TS servers (using differnet signal number and CTI link), two agent client application and three stations.

Problem Clarification

Scenario1:
-          Station1  calls on VDN 1 : This VDN has a vector number which has queue to skill method
-          Agent1 with station2 accepts the interaction and transfers the call via softphone to VDN2.
-          This VDN2 has queue to skill method as well
-          Agent2 with station3 receives the call and accepts interaction
 
Result: Call transferred successfully, but new EDUID was created when call was transferred
 
Scenario 2: Same test as above, but at VDN1, we used adjunct route skill method.
 
Result: Call transferred successfully and no new EDUID was created.

Cause

The reason why a new EDUID was created in the first scenario is basically a product limitation. When we have adjunct route, we have the TS.Route event triggered during transfer. This even contains the UUI information with EDUID and when the call is transferred the information is pasted to the other TS. And hence no EDUID would be created.

On the other hand when queue to skill method is used, there is no TS.Route method.

Solution

Use Adjunct routing method in the vector such that TS events contains the UUI information.


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