IP DECT: Leading 0 for PSTN Trunks is missing in call log for missed calls


Doc ID    SOLN214464
Version:    4.0
Status:    Published
Published date:    21 Sep 2022
Created Date:    16 Nov 2012
Author:   
kasperczyk
 

Details

Callback from call log does not work. The leading 0 for outside line is missing for some calls.
IP DECT R3
ADMM: IPBS[3.2.8], Bootcode[3.0.26], Hardware[IPBS1-Y3 /1D]
AIWS2: Software Version 3.13-A, Hardware Type Elise3 Lite
ACM: S8800-015-02.1.016.4-18250

Problem Clarification

Several DECT phones cannot call back from call log. The leading 0 for a PSTN Trunk is missing. There should be something like 00211xxxxxxx, but after dropping the call the entry in the call log contains 0211xxxxxxx. The leading 0 for a PSTN Trunk is missing, so the number cannot be called back.
Its not with all DECT Phones, but it happens with extensions 2840,2841,2842,2843,2844,2845.
The same issue also happens in the second DECT System for the location Saarbruecken (separated DECT, same CM, separate PSTN and DECT Trunks).

Cause

Made wireshark on IP Trunk to DECT. In wireshark we could see that the Setup Message from CM contains ring type pattern 0 when the call log is wrong and pattern 1 when the call log was correct. DECT interprets pattern 0 as internal and pattern 1 as external.

All calls were made from the same external number, but CM handles them different for different DECT Extensions.

 

Solution

DECT is working as designed. Investigation on CM is needed why a call to Extension A is with pattern 0 and call to Extension B is with pattern 1.
Applicable for all ACM software versions.


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