IQ Real time feed for Agent info from IQ to WFM was not working


Doc ID    SOLN218704
Version:    2.0
Status:    Published
Published date:    16 Dec 2014
Created Date:    18 Jan 2013
Author:   
bairdl
 

Details

Real time feed for Agent info from IQ to WFM was not working.

Problem Clarification

They were not getting the Agent info from IQ sent to their third party application.

Cause

Was not able to determine the root cause.

 

Solution

The customer was able to rerun the interval through the psmenu to successfully get the data


To access the IQ interfaces administration menu via SSH terminal emulation (e.g. via PuTTY):

Login directly to the “psmenu” main menu by logging into the designated Avaya IQ Reporting Host as ‘psadmin’ 

 

Alternatively

1)    Login to the Linux OS of the designated Avaya IQ Reporting Host as ‘root’ or ‘cust’.

2)  At the Linux OS prompt, Enter:  su - psadmin

 

When finished, “Quit” out of the menu and log out of the Reporting Host.

 =============================================================================================

 

Example “psmenu” Main Menu

 

Avaya IQ Interfaces Main Menu

1) rt_socket

2) rta_bp

3) bp

Q) EXIT

Please make a selection:

 

 

Example Real-time Interface Administration Menu

 

------ IEX-RTA Real-time Interface Menu ------

 

1) Start IEX-RTA Real-time Interface

2) Stop IEX-RTA Real-time Interface

3) Check Interface Status

4) View Interface Maintenance Log

5) Show Interface Version

6) Show Interface Licensed Authorizations

7) Show Configuration Information

Q) Quit

=============

Choice ==>

 

Example Historic Interface Administration Menu

 

For help please call Avaya - (866)282-9266

Use this menu to recover missing intervals and for troubleshooting

For daily reports run the recovery selection for the interval defined below

 

Interval reports can be identified by ALL in the INTRVL field

__________________________________________________________

Current Configuration - version_1.0.50

SESSION INTRVL  REPORT      DESTINATION     GROUP         

OFF 1   ALL(30) queue       wild1:/tmp      Queue Group EIDs=2

OFF 2   ALL(30) rp          wild1:/tmp      Routing Point Group EIDs=2

OFF 3   0100    agent       wild1:/tmp      Work Group EIDs=2

__________________________________________________________

      1) Recover one interval

      2) Recover multiple intervals

      3) Recover one day (all intervals)

      4) Recover multiple days (all intervals)

      5) View log (new to old)

      6) View log (old to new)

      D) Debug menu (for troubleshooting only)

      T) Turn on/off a session from running automatically

      Q) Quit

 

Selection:


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