Operational Analyst, Contact Analyzer: How to recollect CMS Call History data


Doc ID    SOLN222595
Version:    6.0
Status:    Published
Published date:    25 Mar 2025
Created Date:    05 Mar 2013
Author:   
alyssape
 

Details

All versions of OA, CA, CMS and CMS feeds.

Problem Clarification

Process to resend data to OA, CA.

Cause

Unknown - Data missing from OA or CA.

Solution

Sample recovery.txt below customer will find a copy of the recovery.txt file on their CMS server in the /export/home/pserv/ech cat recovery.txt

                                                 10/21/08

                 Instruction Sheet for ECH Data Recovery
               (applicable to ECH Handler package for CMS)


NOTE:  These are self-help instructions targeted at personnel with at
       least fundamental Solaris (UNIX) command line skills.  If you are not
       skilled/experienced enough with UNIX to work at a command line level
       it is recommended that you contact Avaya Professional Services at
           1-866-282-9266, prompts 1-1-5.  Administration and maintenance work
           performed by Avaya Professional Services is NOT covered by CMS
       Maintenance Agreements.  All ECH data recovery work done by Avaya
       is billable.


To resend ECH data to OA, Analyzer, etc.

1) login to CMS as 'root'
c

2) Enter:  cd /cms/ech_data/archive


3) Enter:  ls -lt | more


4) Determine the desired file.  The file names are in the format YYYYJJJ.Z
   or YYYYJJJ.bz2 where YYYY is the year, JJJ is the Julian day the file was
   created.  '.Z' indicates that the file was compressed with the 'compress'
   utility.  '.bz2' indicates that the file was compressed with the 'bzip2'
   utility.

   As an example, if you are seeking the ECH data files that were created on
   July 27, 2006 the file name would be 2006209.Z or 2006209.bz2.  The 209
   indicates July 28th, the day the archive was created.  You can also look
   at the time stamp of the file (with 'ls -lt') to see when it was created.
   Remember that ECH data files are archived the day following collection.


5) Enter:

   cp  2006209.Z  ../recovery     # copy the file to the 'recovery' directory)
         OR
   cp  2006209.bz2  ../recovery   # if a .bz2 file

   cd  ../recovery

   uncompress  2006209.Z   # if a .Z file
         OR
   bunzip2 2006209.bz2     # if a .bz2 file

   cpio  -ivm  <  2006209         (extract the files from the CPIO archive)
   rm  2006209

   NOTE:  Uncompressing multiple compressed files can result in using up
                  all the free space on the /cms partition and crashing CMS.  Do
                  NOT uncompress more than one compressed file at a time.  If
                  recovering multiple days, uncompress one compressed file, proc
ess
                  it, then remove the files in the 'recovery' directory before
                  copying in and uncompressing the next compressed file.


6) The 'recovery' directory will now contain all the binary ECH files that
   where extracted from the compressed CPIO archive file.  These files
   will be named chrXXXX.nnn.  You now need to re-queue the particular file
   or files that you want to be retransmitted.  Note that you may
   unintentionally resend data that is already in the receiving database.
   This should not be a problem since a correctly configured database table
   will simply reject those data records that are duplicates.

   You may look at the time stamp of the files with the "ls -lt" command to
   determine which file(s) you desire to requeue.

   Enter:  ls -lt | more
   (we'll use the file chr1201.001 as an example)


7) To re-queue files:

   To send the file to NICE Analyzer/Explorer, enter:
     cp chr1201.001 /cms/cvx_queue

   To send the file to a 2nd Analyzer/Explorer (or ISM), enter:
     cp chr1201.001 /cms/ism_queue

   For files that are to be converted to ASCII for a custom application,
   enter:
     /export/home/pserv/ech/ascii_resend chr1201.001
     OR
     /export/home/pserv/ech/ascii_resend2 chr1201.001

   To send the file to Avaya OA, enter:
     /export/home/pserv/ech/OA_resend chr1201.001

   To send the file to Aspect DataMart, enter:
     /export/home/pserv/ech/Aspect_resend chr1201.001


8) If there is a large number of files that need to be requeued, the
   appropriate above command may be embedded into a 'for' loop.  Sending
   files to NICE Analyzer is used as an example.  It is recommended to put
   the 'for' loop into a file (create a script) for future use.  Be sure
   to make the file executable (example:  chmod +x <file>).

   cd /cms/ech_data/recovery
   for file in `ls chr*`        <== use back ticks, not single quotes
   do
       cp $file /cms/cvx_queue
       rm $file
       echo "$file copied"
   done

cp chr1201.001 /cms/cvx_queue

/export/home/pserv/ech/OA_resend $file

Note:  Each morning when the ECH archiver (ech_archive) runs it removes
       everything in the 'recovery' directory.

Note:  If the time stamp on the file is older than 24 hours, the ftp script
       will delete it, not send it.
#

BBE's notes:  In /cms/ech_data subdirectory you can create a small script (per recovery.txt instructions) named chrrecovery that will process the chr files in bulk and then using the "chmod 755 chrrecovery" command made the script executable.

 
(r3walal)-(root2)=# cat chrrecovery
cd /cms/ech_data/recovery
for file in `ls chr*`
do
/export/home/pserv/ech/OA_resend $file
rm $file
echo "$file copied"
done
 

Additional Relevant Phrases

cmscallhistory recorder stopped working Need to recollect CMS Call History data

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