SAL Gateway is automatically denying all remote session requests with Policy Server set to "Ask for permission".


Doc ID    SOLN223864
Version:    3.0
Status:    Published
Published date:    21 Jun 2016
Created Date:    19 Mar 2013
Author:   
jrampy
 

Details

SAL Gateway is automatically denying all remote session requests with Policy Server set to "Ask for permission".

Problem Clarification

SAL Gateway is automatically denying all remote session requests with Policy Server set to "Ask for permission". The Policy Server that the SAL Gateway is using for its policies is set to "Ask for permission" on all remote access requests. The remote engineer should see the message "Waiting for Authorization" on their SAL session window. Instead, the session window goes to "Permission Denied" automatically.

Cause

The SAL Gateway is not able to communicate with the Policy Server properly due to a hostname mismatch on the SAL Gateway itself. The hostname of the server that the SAL Gateway is running on does not match the entry for the hostname of the SAL Gateway in the application itself or on the RHEL OS when you run the command "hostname".

Solution

Check the hostname entry in /etc/sysconfig/networking/devices/ifcfg-eth0 and make sure it is set correctly for the proper hostname of the server as configured in the RHEL OS. Run the command "hostname" to see what the RHEL OS says the hostname is and confirm that it matches the same in that file. If the hostname command gives a different output than what the hostname field shows in that file, then check the RHEL OS setting for the domain name of the DNS search domain and make sure it shows the correct domain name. IE: The hostname command shows this "salgwserver.customernetwork.custnet2.com" and the actual hostname in the /etc/sysconfig/networking/devices/ifcfg-eth0 file shows as "salgwserver.customernetwork.com". If this is the case, correct the DNS search domain name as it is more than likely "customernetwork.custnet2.com" and change it to "customernetwork.com" to match the actual domain name that the SAL Gateway is in. Also, log into the GUI interface of the SAL Gateway and make sure that the hostname seen in the upper right hand corner also matches the correct hostname for the server and then verify that the hostname on the SALGW managed element also matches the correct one. Do this by logging into the SALGW GUI and go under the "Administration" section then "Gateway Configuration" and select "Edit" to make changes then "Apply" to save them and go to "Apply configuration changes" at the bottom of the "Administration" section and click "Apply" then "OK". This will restart the SALGW services to apply the changes to the application. Then check remote access to the system and verify the Policy Server is in use by verifying you see "Asking permission" on your remote session.

Additional Relevant Phrases

SAL Policy Server does not manage remote sessions correctly.

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