Avaya one-X Attendant, phone book not working


Doc ID    SOLN224255
Version:    2.0
Status:    Published
Published date:    24 Aug 2015
Created Date:    25 Mar 2013
Author:   
Izabela Tymkow
 

Details

Avaya one-X Attendant, phone book not working

Problem Clarification

This is new install of version 4.02.010.000.(ACM)

The problem was that we couldn't search in the intergraded phone book, but the busy display collected the names from it to display. Export of the phone book always failed as well.
Import was not a problem, but special Icelandic characters where all messed up and not eligible.

 

Cause

This is curst by the client PCs "Region and Language" is set to Icelandic (Iceland) (as are all PC's in the country), so the system was looking for a file called TextBundle_is.properties, witch is not present in the installation file. This took awhile to figure out.

 

Solution

The Fix
Create a new TextBundle file "TextBundle_is.properties" and restart the "Avaya one-X Attendant Database" service and "Avaya Phonebook Server" service.
Then we have to encode phone book txt file to ANSI for the special Icelandic characters.

 

This is curst by the client PCs "Region and Language" is set to Icelandic (Iceland) (as are all PC's in the country), so the system was looking for a file called TextBundle_is.properties, witch is not present in the installation file. This took awhile to figure out.

The Fix
Create a new TextBundle file "TextBundle_is.properties" and restart the "Avaya one-X Attendant Database" service and "Avaya Phonebook Server" service.
Then we have to encode phone book txt file to ANSI for the special Icelandic characters.

Something for Avaya producthouse to fix:
When system can't find proper TextBundle_XX.properties file (like TextBundle_en.properties or something) it needs to fall back to a default one, not almost work, but not quite !!!

 

This apply to other countys for example Belgium. If you have this problem please check files available in Avaya\Servers and create one for your location


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