CMS: Unable to run desginer reports


Doc ID    SOLN228168
Version:    7.0
Status:    Published
Published date:    23 Sep 2020
Created Date:    09 May 2013
Author:   
Mauricio Burgo
 

Details

CMS: Any version

Problem only with designer reports. Standard reports worked fine.

Will also show up in external feed logs (such as RTA Geo).

Problem Clarification

Customer had a power outage and after restart the CMS he was not able to run design reports. CMS Supervisor client was getting this message:

Elog had the errors bellow: The server was unable to execute the query for this report Correct the problem and try again contact technical support

Elog showed:

00500 Thu May 09 10:22:21 2013  SRC_ERR_NUM=00017 PROCESS=idbm           PID=000877                usr_msg.c:00900 SEVERITY=ERROR ACD=00 DUPS=00110 UNIX error on OPEN, file: /cms/tmp/cms.AADn877

01302 Thu May 09 10:22:21 2013  SRC_ERR_NUM=-00004 PROCESS=idbm           PID=000877                  DbSql.c:00507 SEVERITY=INFO  ACD=00 DUPS=00110 PROCESS COMMUNICATIONS (PO) library error, zunction: usr_msg::set_obj

02806 Thu May 09 10:22:21 2013  SRC_ERR_NUM=-29055 PROCESS=acsRep         PID=014440                 DaleData:00100 SEVERITY=ERROR ACD=01 DUPS=00001 COW Application Error: PCH = 24 : Time = 10:22:21 : [CVS V16.0 KD.19] QueryError: pos=0 query=QUERY0 qi=0 path=23 report=YYYY : LOGIN=xxxx

02806 Thu May 09 10:22:21 2013  SRC_ERR_NUM=-00340 PROCESS=acsRep         PID=014440     cvsReport:ExportData:00010 SEVERITY=ERROR ACD=00 DUPS=00002 COW Application Error: PCH = 0 : Time = 10:22:21 : [CVS V16.0 KD.19] Historical\Designer\YYYY: VB error (340) Application-defined or object-defined error: LOGIN=xxxx 

When tried to run CMS's error log report was getting a "Query was unsucessfull due to a database error"

RTA Geo feed log shows "WARNING: Screen Painter report failed while running.  Restarting", and when checking elog, it shows "GENERAL error internal to process: disk may be full".

Cause

Found out that /cms/tmp was full of temporary files generated every few minutes for the past 4 months. Have them removed and CMS's design reports and error log report started to work successfully.

Solution

Manually remove the contents of /cms/tmp. There is no impact to the CMS Server or clients.


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