AES: TSAPI error code 9


Doc ID    SOLN237987
Version:    2.0
Status:    Published
Published date:    11 Oct 2016
Created Date:    09 Oct 2013
Author:   
Shane E Roussie
 

Details

Verint recorder indicated that the TSAPI link dropped from Application Enablement Services (AES) and reported a TSAPI error code 9 as the cause.

Problem Clarification

TSAPI error code 9 is a universal failure, indicated in the Device media call control API XML Programmer's Guide (attached below)

Stream error - ACSERR_UNKNOWN - 9 The ACS Stream has encountered an unspecified error.

Error in the Verint logs.
08/28/13 13:29:25.515 (-04) TSAPI Critical tsapiPbxThrds.cpp 208 INFOLINK CONNECTION PROBLEM: TSAPI EventsThreadHandler - Received error number -9 from TSAPI client, error description: 'The ACS Stream has encountered an unspecified error'
08/28/13 13:29:25.515 (-04) GENERIC_NAV_FACTORY Verbose Subscriber.cpp 868 Subscriber: SwitchConState ConState DISCONNECT ConStateInfo TSERVER_FAILURE switch_id 1
08/28/13 13:29:25.515 (-04) IL_STATUS_MAIL Noncritical Subscriber.cpp 872 Infolink is Disconnected
08/28/13 13:29:25.515 (-04) GENERIC_NAV_FACTORY Noncritical Subscriber2.cpp 526 Subscriber2: SwitchConState ConState DISCONNECT switch_id 1 process_id 9996
08/28/13 13:29:25.515 (-04) GENERIC_NAV_FACTORY Noncritical Subscriber2.cpp 532 Subscriber2::SwitchConState called with disconnect event: Signalling exit-trigger to terminate EH
08/28/13 13:29:25.515 (-04) GENERIC_NAV_FACTORY Noncritical Kamikaze.cpp 35 Exit-trigger was signaled to terminate EH...

Cause

This particular error means that something went wrong in the TSAPI client dll and the error generated did not fall into one of the pre-defined categories, hence it being reported as a universal failure. Most likely the AES received some request from the application that was processed in the TSAPI library but was undefined; as a result the AES did not know how to complete the request and this error was generated.
 

Solution

No resolution can be provided at this time as each application interacts with the AES differently.

To troubleshoot the issue further, if the application has logging of its interaction with the TSAPI client, then enabling that logging and comparing that to the TSSPY output with the applications dev team may yield some information as to an exact cause.

Attachment File

Device media call control API XML Programmers Guide.pdf
1.8MB • 5 minute(s) @ 56k, < 1 minute @ broadband



Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy