One-x Mobile Lite 6.2: One-x Mobile when initiate the call, it takes more than 10 seconds to ring the called party.


Doc ID    SOLN238006
Version:    4.0
Status:    Published
Published date:    28 Nov 2017
Created Date:    10 Oct 2013
Author:   
Rutuparn Pandey
 

Details

One-x Mobile Lite 6.2

swversion
     Operating system:  Linux 2.6.18-238.AV02xen i686 i686
                Built:  Aug 26 09:25 2011

             Contains:  02.0.823.0
        CM Reports as:  R016x.02.0.823.0
    CM Release String:  vcm-016-02.0.823.0
     Publication Date:  27 December 2011

 patch 20558 for 02.0.823.0

 

Problem Clarification

One-x Mobile lite when initiate the call using the pre configured FNE's, the call reach to CM and sent to service provider, but service provider had introduced about 10 sec delay to process the call.

One-x Mobile logs shows as below:

com.avaya.android.onex.HistoryActivity@42146448
D/oneXApp (20014): oneXApp:T:OneXActivity.onBackPressed()
D/oneXApp (20014): dpad:onCreate()
D/oneXApp (20014): prefs:LoginPreferenceSet: false
D/oneXApp (20014): prefs:LoginPreferenceSet: false
D/oneXApp (20014): AndroidDialer:Dialing: +31592xxxxx,00621xxxxxx
D/oneXApp (20014): AndroidDialer:Dialing: +31592xxxxx,00621xxxxxx
D/oneXApp (20014): SendLogs:Sending Logs...
D/oneXApp (20014): oneXApp:T:getLogEmailSubject: Android: Avaya… Error Logs

CM list trace shows below information

09:36:24 TRACE STARTED 10/10/2013 CM Release String cold-02.0.823.0-20558
09:36:31     Calling party station      59xx cid 0xdfa
09:36:31     Calling Number & Name 59xx Tuik 2e numme
09:36:31     active station      59xx cid 0xdfa
09:36:31     tone-receiver       01D1308 cid 0xdfa
09:36:31     feature name extension       5027 cid 0xdfa --> Here it introduces the delay.
09:36:46     dial 00621xxxx route:ARS
09:36:46     term trunk-group 1      cid 0xdfa
09:36:46     dial 00621xxxx route:ARS
09:36:46     route-pattern  1 preference 1 location 1/ALL  cid 0xdfa
09:36:46     seize trunk-group 1 member 7    cid 0xdfa
09:36:46     Setup digits 0621xxxx
09:36:46     Calling Number & Name 592xxxxxx Tuik 2e numme
09:36:46     Proceed trunk-group 1 member 7    cid 0xdfa
09:36:54 TRACE COMPLETE trunk-group  2 cid 0xdfa


 

Cause

With the MST analysis by CM team, it is found that the delay was caused at 2 places.

1) during the Dialed digits sent from the Mobile after the FNE, this was delay of around 10 secs, depending on the length of the dialed number as the number are sent as DTMF digits. This happens on One-X mobile for Android only. One-X mobile for iOS does not have such delay.

One-X mobile for Android has 2 options: FNE setup Delay is the timer which can control the time between FNE and actual number to be sent to CM so that CM can distinguish between FNEs and dialed number.

2) After the digits are reached to CM, CM is initiating the dial out but the service provider is taking time of more than 15secs to progress the request, which is a concern.  

 

Solution

Involve CM team to work on the issue. After looking at MST it is found that the service provider is causing the major delay and customer need to contact service provider to fix this issue.

Additional Relevant Phrases

On another issue, isolated these incidents to home users on laptops (wi-fi) using Computer Mode w/usb headsets.

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