Interaction Center : AAWC client message is received " Lost Connection to Chat Server"


Doc ID    SOLN239446
Version:    3.0
Status:    Published
Published date:    27 Dec 2016
Created Date:    04 Nov 2013
Author:   
ghorpades
 

Details

webchat agent unable to answer chat getting lost connection message
IC 7.3, Window 2008, Chat Service

Problem Clarification

In IC 7.3, some of group of agent when the chat is assigned to the agent the agent receives the message " Lost Connection to Chat Server"

Cause

when the chat is initiated by the customer it gets assigned to the agent, after which the customer should be able to chat with the agent. The control of the whole chat session is taken by ICM Service . If the connection to ICM service is lost we could see the error as seen in your environment.

AvayaDebug.log

2013-09-23 14:20:25,073|DEBUG|com.avaya.ic.uom.channel.chat.protocol.ChatDocImpl|Thread-631||||setActivity(): oldActivity=DROPPED_CALL newActivity=CONNLOST|[]
2013-09-23 14:20:25,073|DEBUG|com.avaya.ic.uom.channel.chat.ChatChannelConnectionImpl|Thread-631||||ICM ChatDoc[nvmp-aicext-01.sageukie.adinternal.com] ACTIVITY occurred: CONNLOST, Reason: Ending the chat server connection... The chat server ended the connection unexpectedly.|[]
2013-09-23 14:20:25,073|DEBUG|com.avaya.ic.uom.channel.chat.protocol.ChatDocImpl|Thread-631||||ChatDoc::markDisconnected() Disconnecting ChatDoc [nvmp-aicext-01.sageukie.adinternal.com]|[]

Solution

1) engaged your network team check , if there is a glitch in the network or , connection between the machine where ICM Service is installed and the attribute Server/Workflow/AAWC is installed.
2) Enable Attribute Heart Beat on the website context.
3) Enable ICMBridge Connectivity Option on the Icm Node 30 60 604800

Configured Agent connectivity option as 60 600 1200 Sec.  This will ensure it will wait for  1200 sec before disconnecting the connection of inactivity.

Additional Relevant Phrases

Interaction Center: AAWC chat lost connection to chat server

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy