Voice Portal: Intermittent drop calls - Call transfers are failing


Doc ID    SOLN241956
Version:    1.0
Status:    Published
Published date:    28 Mar 2014
Author:   
lcenteno
 

Details

Transferred calls misrouting across enterprise. Agents are receiving dead air calls.
Issues started to happen after the developers made the execution of the store procedures more efficient.

VP 5.1 SP2

 

Problem Clarification

Call transfers are sometimes failing.

Cause

The VP application receiving the calls is transferring them very fast, as soon as it receives them. As this customer has shuffling enabled in the CM, the INVITEs and reINVITEs from the initial call setup are interfering with the INVITEs and REFERs from the call transfer.

When the call transfers fail we are seeing SIP message "491 Request Pending"

Solution

We are using a custom ccxml file. For the Blind transfers we added 2 secs delay after receiving the call and starting the call transfer. For Consultative Transfer we applied hot fix 5.1.0.2.0334 on top of SP2.


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