CM,1408 Digital Phone: Firmware download to the phone set fails with error: "Bad file on server: Wrong file header"


Doc ID    SOLN244344
Version:    1.0
Status:    Published
Published date:    05 Feb 2014
Author:   
ghegyessy
 

Details

Communication Manager: any version
All Digital (DCP) sets 

Problem Clarification

Firmware file is downloaded from the Avaya support site (http://support.avaya.com) and uploaded to a TFTP server. Whenever the file is about to be uploaded to the Communication Manager via "change tftp-server" command the uploade fails with error code: "Bad file on server: Wrong file header"

Cause

Upon further investigation and verifying the checksum of the firmware file it turned out the file got corrupted during the download.

Solution

Make sure the internet connection / local network are free of errors. Clear the cache of the web browser and the web proxy. Download the file again and verify checksum with MD5 checker:

  • in Linux use "md5sum <filename>" command,
  • in Windows you may use "WinMD5" application

to get the checksum of the downloaded file. Then compare it with the checksum shown on the suport site. If they match upload the file to the TFTP server and retry the "change tftp-server" command.


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