This is the error: org.apache.axis.ConfigurationException: No service named VPReport4 is available org.apache.axis.ConfigurationException:


Doc ID    SOLN244764
Version:    1.0
Status:    Published
Published date:    12 Feb 2014
Author:   
Praveen Gopi
 

Details

VP error message on logs
No clear effect of the error message

What log did you see this error?
-Stdout.log under Tomcat

No changes on the system

VP 5.1 SP 2

TS done:

“Edit the voiceportal.properties file on the VPMS and configure the correct IP-address for the 'appLoggingURLvp4' parameter and then restart the VPMS service via the command line. 1. Edit opt/Tomcat//webapps/VoicePortal/WEB-INF/classes/config/voiceportal.properties file and change the parameter appLoggingURLvp4=https:///axis/services/VPReport4 2. Restart the VPMS services # service vpms restart
1. Edit opt/Tomcat//webapps/VoicePortal/WEB-INF/classes/config/voiceportal.properties file and change the parameter
appLoggingURLvp4=https:///axis/services/VPReport4
2. Restart the VPMS services
# service vpms restart”

Remote access: LMI

Problem Clarification

VP error message on logs

This is the error: org.apache.axis.ConfigurationException: No service named VPReport4 is available org.apache.axis.ConfigurationException: No service named VPReport4 is available at org.apache.axis.configuration.FileProvider.getService(FileProvider.java:233) at org.apache.axis.AxisEngine.getService(AxisEngine.java:311)

Cause

DD trace for CLB application and you are observing an exception with respect to the VPreport4 service. The VPReport4 service is responsible for getting the data from the application on the tomcat to the EPM so that the “Application Detail Report” is populated with the data ( if configured in the application).

Solution

However, this service is not responsible for writing the logs into the DD trace log. I believe there might be some configuration/library issue during the upgrade.
Customer has to deploy their CLB Application on the latest DD 5.1 version, compile it and check if it works.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy