CDR - calling-num National or International number - how get this ?


Doc ID    SOLN244952
Version:    1.0
Status:    Published
Published date:    14 Feb 2014
Author:   
OLIVIER PIOU
 

Details

CDR question about incoming call - HOW to differ Natioanl and international of the Calling Number

On incoming call, some national and international calling

test done on this version of Software Load: R016x.02.0.823.0 patch 20558 / VSP=6.2.1.3.9
 

Problem Clarification

CDR question about incoming call - HOW to differ Natioanl and international Calling
On incoming calls, the Calling Number collected on CDR is not fully classify !! so it’s not possible to differ to a national and an international number.
For example, hereafter some CDR ticket give some example of confusion:
this Calling number ‘049152xxxxxxxx’ => is it a number come from Dutch country, with 049xx or local French 049xx => like the number is more than 10, it’s a DE country
this Calling number ‘049xxxxxxxx’ => is it a number come from Dutch country, with 049xx or local French 049xx

NEXT : need to get a way to differ a national and an international Calling number
need to get a way to add on Calling Number the 0 when it’s a national number and a 00 for any international number.

Cause

no cause - working as design

Solution

All number come from the service provider has been routed to the CDR with same : no modification has been done.

Unfortunately, we cannot change the format of an incoming number to be presented to CDR for reporting, it’s working as designed and sending the digits that are getting from SP to CDR.

The service provider is sending digits to switch for local French numbers 049xxx, if they are not adding country code 33, then ask them to send the digits including country code to switch to distinguish the incoming numbers between Dutch and local France for CDR report.

example of call traced

CDR details and format define

Date6

time4

out-crt-id3

code-used4

code-dial4

calling-num15

dialed-num18

spec-dur5

isdn-cc11

cond-code1

auth-code7

acct-code15

attd-console2

vdn12

frl1

node-num1

clg-num/in-tac10

in-crt-id3

in-trk-code4

ppm5

ucid20

line-feed1

112213

1210

 

 

 

49152xxxxxx91

331xxxxxx11

00012

0

G

 

 

 

 

0

1

52xxxxxx91

059

#01

0

0000904243nnnnnnnn14

 

112213

1210

 

 

 

49152xxxxxx91

331xxxxxx11

00016

0

9

 

 

 

 

0

1

52xxxxxx91

059

#01

0

0000904243nnnnnnnn14

 

                                           

112213

1210

 

 

 

49xxxxxx80

331xxxxxx97

3

0

G

 

 

 

 

0

1

49xxxxxx80

10

#01

0

0000904246nnnnnnnn40

 

112213

1212

 

 

 

49xxxxxx80

331xxxxxx97

112

0

9

 

 

 

 

0

1

49xxxxxx80

10

#01

0

0000904246nnnnnnnn40

 

 

> list trace sta 331xxxxxx15

12:04:13     Calling party trunk-group 1 member 10    cid 0x36d7

12:04:13     Calling Number & Name 04xxxxxx06 NO-CPName

12:04:13     dial 331xxxxxx15

 

 

some more KB for explanation:

SOLN137637 : CM: Unable to see CPN prefix in CDR output

ADMN100757 : CM, S8XXX: How to check fields in the CDR output

ADMN101212 : CM: How to verify Call Detail Recording (CDR) is administered correctly

 

 

 

 

 

CDR ticket generated and send by ACM to the external CDR engine:

 

 

**** international call

> list trace sta 331xxxxxx15

[7;0H11:27:08 TRACE STARTED 02/13/2014 CM Release String cold-02.0.823.0-21049

[8;0H11:30:47     Calling party trunk-group 1 member 12    cid 0x3660

[9;0H11:30:47     Calling Number & Name 049xxxxxxxx91 NO-CPName

[10;0H11:30:47     dial 331xxxxxx15

...

 

CDR ticket generated and send by ACM to the external CDR engine:

     021314 1130                 04916xxxxxx91        331xxxxxx15 00005           0 H                                         0 1 162xxxxx91 012  #01     0 00009139nnnnnnnnnn47                                      

CDR Ticket collected by the external CDR engine name : NOVA

      [11:30:52]{ACTION=COMMUNICATION|PosteDmde=331xxxxxx15|NumComp=0491xxxxxxx91|HeureDureeSonn=0|MinDureeSonn=00|SecDureeSonn=05|SecDureeConv=0|NumReseau=|NonAbouti=1|Entrant=1|Extern=1|Abouti=0|JourFin=13|MoisFin=02|AnneeFin=14|HeureFin=11|MinFin=30|Taxes=0|Clef=|IdConf=|CodProc=1|CodeTicket=0|Signature=H|NumComm=00009139nnnnnnnnnn47|SDA=}           

Fin d'aboutement (0)                                                 

 

**** national call

   021314 1204                    04xxxxxx06        331xxxxxx15 00013           0 9                                         0 1 04xxxxxx06 010  #01     0 00009140nnnnnnnnnn53

CDR Ticket collected by the external CDR engine name : NOVA

   [12:04:46]{ACTION=COMMUNICATION|Intern=0|Extern=1|Abouti=1|Entrant=1|PosteDmde=331xxxxxx15|NumComp=04xxxxxx06|HeureDureeConv=0|MinDureeConv=00|SecDureeConv=13|NumReseau=#01|JourFin=13|MoisFin=02|AnneeFin=14|HeureFin=12|MinFin=04|Taxes=0|Clef=|IdConf=|CodProc=1|CodeTicket=0|Signature=9|NumComm=00009140nnnnnnnnnn53|SDA=} Fin d'aboutement (0)


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