CM6.3: Software requested interchanges and resets


Doc ID    SOLN245586
Version:    3.0
Status:    Published
Published date:    21 Mar 2016
Created Date:    25 Feb 2014
Author:   
kassir
 

Details

CM Primary Server performed two cold restarts this weekend with no known cause. System did not interchange
The cabinets reset, system went down.

init@Aflac-CMB>

RESTART CAUSES for Aflac-CMB
Cause Action Escalated Mode Time
Initialized 4 (RELOAD) no Standby 10/25 22:36
Internal Request 1 (WARM) no Standby 10/25 22:36
Internal Request 1 (WARM) no Standby 10/25 22:36
Update/Upgrade Software i (COOL) no Active 10/25 22:59
Interchange-Craft 4 (RELOAD) no Standby 10/28 22:59
Internal Request 1 (WARM) no Standby 10/28 23:00
Internal Request 1 (WARM) no Standby 10/28 23:00
Initialized 4 (RELOAD) no Standby 10/28 23:09
Internal Request 1 (WARM) no Standby 10/28 23:09
Initialized 4 (RELOAD) no Standby 10/28 23:10
Internal Request 1 (WARM) no Standby 10/28 23:10
Internal Request 1 (WARM) no Standby 10/28 23:10
Initialized 4 (RELOAD) no Standby 02/04 20:55
Internal Request 1 (WARM) no Standby 02/04 20:55
Internal Request 1 (WARM) no Standby 02/04 20:56
Interchange 1 (WARM) no Active 02/10 9:19
init@Aflac-CMB>No system changes were made prior to the system failing. System never interchanged., no changes made.

Problem Clarification

 

Note the ECS logs below are normal with the duplicate CM6.x releases.

init@Aflac-CMB> standby server

20131029:020501619:995:filesyncd(24199):HIGH: [ERROR: doCmd: This server is not ACTIVE.]
20131030:020501289:1015:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]
20131031:020501924:1032:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]
20131101:020501282:1035:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]
20131102:020501338:1040:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]
20131103:020501295:1047:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]
20131104:020501409:1054:filesyncd(24199):HIGH:[ERROR: doCmd: This server is not ACTIVE.]

Cause

Two things. First refer to PSN020094u. The customer changed the 4621 IP stations to 9611.
Second, tier 4 was able to reproduce the problem while testing with customer and how to prevent the problem.
All we have to do is configure CM correctly. Specifically, the proxy select route pattern on the locations form was set to a route pattern that had no trunks. That sends CM into oblivion. The customer changed it to put in a valid route pattern and tested that again and it works fine. That’s all there is to it.

Solution

1. apply PSN020094u as temp fix.
2. load SP4 for CM6.3 that has MR defsw140063.
committed to CM 6.3.4.0 (SP4), which is available in the latest patch # 21291.
3. to prevent the problem all you have to do is configure CM correctly. Specifically, the proxy select route pattern on the locations form was set to a route pattern that had no trunks. That sends CM into oblivion. Need to put in a valid route pattern. That’s all there is too it. MR defsw140269 will prevent this issue from happening in future loads.

4. As to the Software requested interchanges and resets  taking down the system/softphones, we found out there's AES release 5.x while CM is at 6.3. The customer must upgrade to the compatible AES release 6.x.

Additional Relevant Phrases

Standby server went down

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