Intuity Audix LX: Calls drop after the first greeting


Doc ID    SOLN245608
Version:    1.0
Status:    Published
Published date:    26 Feb 2014
Author:   
Jeff Nelson
 

Details

Customer complains that calls are dropped after hearing the first greeting on the Audix

Problem Clarification

Callers hear the greeting on the Audix but then the call is dropped. The issue is intermittent making it tough to narrow down.

Server does need a reboot since it's been up for 210 days which is long past the 90 reboot recommended by Avaya. However, customer says this issue has been going on for a longer period of time.

Cause

Possible POET DB corruption and / or device table needs to be rebuilt. Voice cards should be checked and/or replaced since this is intermittent.

It could be the voice cards and / or the ribbon cable connecting them and not a software issue. It could be both a software and a hardware issue.

Solution

Reboot Audix. Once server is back up,  run following commands-

stop_vs
device table rebuild as per 'SOLN105068'
audit -i2 -a rebuild
start_vs

Next, stop_vs and run Poet DB repair

repair_poet_databases -r -v
post_rst


In this case there were severe file corruptions and the Audix application would not start.

Checking voice file directories ...
Audix Application generic software check PASSED
Audix Application System Data file check PASSED
Announcement presence check PASSED
Database reorganization check PASSED
LDAP data verification ..... PASSED
Reformat of LDAP data ..... ..... ..... PASSED
Attempting to start LDAP Server PASSED
Audix Application Names presence check PASSED
Rebuildable voice data check FAILED
auto voice rebuild will start
Rebuildable translations check FAILED
auto xln rebuild will start
Outcalling database check PASSED
Notification database check PASSED
Admin Notification database check PASSED
Class of Service Notification database check PASSED
Database /vm/audix/sd/sdata/sdl does not exist!
Poet database check FAILED
POET database integrity check failed - database does not exist

To resolve, do the following.

1) Run the Audit rebuild and it will give you error for the files/directories which has the permission issues. See the below example.
IntuityLX%:vexvm> audit -i2 -a rebuild
Error: in open::get base filename:/VM/audix/sd/mail/mb ; POET Error : -2032 -> there is no access to database
creat_index(/VM/audix/sd/mail/mb,6,,664) - btree_create() returns fd=-1 (errno=13 (Permission denied))
audit-177: Cannot create data file </VM/audix/sd/mail/mb>
Error: in open::get base filename:/VM/audix/sd/mail/dr ; POET Error : -2032 -> there is no access to database
creat_index(/VM/audix/sd/mail/dr,5,,664) - btree_create() returns fd=-1 (errno=13 (Permission denied))
audit-177: Cannot create data file </VM/audix/sd/mail/dr>
Error: in open::get base filename:/VM/audix/sd/mail/node ; POET Error : -2032 -> there is no access to database
audit-177: Cannot open data file </VM/audix/sd/mail/node>
Error: in open::get base filename:/VM/audix/sd/mail/node ; POET Error : -2032 -> there is no access to database
creat_index(/VM/audix/sd/mail/node,4,,664) - btree_create() returns fd=-1 (errno=13 (Permission denied))
audit-177: Cannot create data file </VM/audix/sd/mail/node>
Error: in open::get base filename:/VM/audix/sd/mail/xmq ; POET Error : -2032 -> there is no access to database
creat_index(/VM/audix/sd/mail/xmq,4,,664) - btree_create() returns fd=-1 (errno=13 (Permission denied))
audit-177: Cannot create data file </VM/audix/sd/mail/xmq>
Error: in open::get base filename:/VM/audix/sd/mesg/vf ; POET Error : -2032 -> there is no access to database
creat_index(/VM/audix/sd/mesg/vf,1,,664) - btree_create() returns fd=-1 (errno=13 (Permission denied))
audit-177: Cannot create data file </VM/audix/sd/mesg/vf>
Segmentation Fault(coredump)

The system will show errors such as the ones below...

Database permissions are incorrect for /vm/audix/sd/mail/mb
Database permissions are incorrect for /vm/audix/sd/mail/dr
Database permissions are incorrect for /vm/audix/sd/mail/xmq
Database permissions are incorrect for /vm/audix/sd/mail/node


2) Correct the file permission using chown command.

IntuityLX%% chown -R vexvm dr
IntuityLX% chown -R vexvm mb
IntuityLX%chown -R vexvm node
IntuityLX% chown -R vexvm xmq

3) repair_poet_databases -r -v
4) su - vexvm
5) audit -i2 -a rebuild
6) start_vs
7) start_vm (if necessary)

The Audix application came back up and the voicemail was back in service, however, in this case with such severe corruptions, it was recommended to the customer that a complete software reload be done and replace the voice cards along with the ribbon cable. 
 


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