CMS: IBM ODBC Connection failed


Doc ID    SOLN245959
Version:    8.0
Status:    Published
Published date:    15 Sep 2023
Created Date:    02 Mar 2014
Author:   
Dody Peribadi ST
 

Details

CMS R16.x and later

Check current ODBC port status, ports are:

Primary/cms/dc# netstat -an | grep 50001
###.###.###.#.50001        *.*                0      0 49152      0 LISTEN
Primary/# netstat -an | grep 50000
###.###.###.#.50000        *.*                0      0 49152      0 LISTEN


Secondary/# netstat -an |grep 500
###.###.###.###.50000       *.*                0      0 49152      0 LISTEN
###.###.###.###.50001       *.*                0      0 49152      0 LISTEN

Problem Clarification

Customer reported the ODBC link issue. They confimed before they upgrade, ODBC was working fine and they only experience the issue after upgrading the CMS. Nothing is change on CMS system accordig to the customer.

Issue
IBM Informix ODBC Err Messages: Test connection was NOT successful.[Informix][Informix ODBC Driver][Informix attempt to connect to database server (cms_hostname) failed.

 

IP address was found to work fine but DNS did not

Cause

Finding the Host Name (IP address) that configured for ODBC Driver setup on Windows, Control Panel\System and Security\Administrative Tools --> Data sources (ODBC) --> User DSN --> amextest1  IBM INFOFMIX ODBC DRIVER (64-bit) is incorrect IP Address.


Server Name cms_hostname
Host Name ###.###.###.##  --> incorrect IP Address. This is not CMS IP that the ODBC ports are listening the correct IP add is ###.###.###.#
Protocol olsoctp
Protocol
Database Name cms
.
.
.

 

DNS had not been set up

no info available on resolve.conf

Solution

1. Make sure the ODBC environment is correct
   Amex_Primary/opt/informix/etc# hostname
   hostname
   Amex_Primary/opt/informix/etc# cat /opt/informix/etc/sqlhosts
   cms_ol onipcstr hostname cms_ol
   oacms_ol onipcstr hostname oacms_ol
   cms_net ontlitcp hostname 50000
   cms_hostname ontlitcp hostname 50001
   cms_pri ontlitcp        primary pri_soc
   cms_sec ontlitcp        secondary       sec_soc

   SERVERNUM 1
   DBSERVERNAME cms_ol
   DBSERVERALIASES oacms_ol,cms_pri,cms_net,cms_hostname

2. Check with command onstat -g glo | grep tli if ODBC process is running (CMS r15 and later)
   Primary/# onstat -g glo |grep tli
   tli         1         1.55      2.24      3.79   
   70    903       tli         1.55      2.24      3.79      NA         NA

3. Go to Windows, Control Panel\System and Security\Administrative Tools --> Data sources (ODBC) --> User DSN --> amextst1 --> click on configur button. On Connection tab --> correct Host Name IP Address, replace the IP address with ###.###.###.#. And then on Environment tab,confirm the Database Locale = en_US.57372 and make sure you check (check box) Use Server Database Locale.

4. And finally Apply & Test Connection, IBM Informix ODBC Message: Test connection was successful.

 

Additional Relevant Phrases

CMS: IBM ODBC Connection failed

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