SMGR: End user cannot access web interface due to exceeded CPU usage, connection to ACM not working. Incoming calls to ACM (SM1) not working properly


Doc ID    SOLN248144
Version:    17.0
Status:    Published
Published date:    31 Mar 2022
Created Date:    08 Apr 2014
Author:   
 

Details

Customer can't login into SMGR web interface, utilization CPU 101.3%, mem 71.1 for JAVA command, connection to ACM not working. Incoming calls to ACM (SM1) not working properly

Changed incoming call to ACM and outgoing call from ACM (without SMGR). But in the same time when incoming calls to ACM (SM1) not working properly, outgoing calls running properly (SM2). There are two connection actually on SM2 and none for SM1. SMGR wasn't yet restarted. We need your help to test why java process was destruction our system.

SMGR version  : 6.3SP2, which is 6.3.2.4.1399.

SM Version 6.3.0.0.630039

System Platform

Problem Clarification

Java process was using CPU on 101.3% and the Memory 71.1% for JAVA command, connection to ACM not working. Incoming calls to ACM (SM1) not working properly

[root@aka1smgr ~]#  tail /opt/Avaya/JBoss/6.1.0/jboss-as/server/avmgmt/log/server.log
2014-04-08 11:45:34,280 ERROR [org.apache.catalina.core.ContainerBase] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Exception invoking periodic operation: : java.lang.OutOfMemoryError: Java heap space

2014-04-08 11:45:34,292 ERROR [org.hibernate.util.JDBCExceptionReporter] (PantherQuartzScheduler_Worker-70) Transaction is not active: tx=TransactionImple < ac, BasicAction: 0:ffffc0a8cc11:1396:5188ee9e:779fb4e status: ActionStatus.ABORTED >; - nested throwable: (javax.resource.ResourceException: Transaction is not active: tx=TransactionImple < ac, BasicAction: 0:ffffc0a8cc11:1396:5188ee9e:779fb4e status: ActionStatus.ABORTED >)
2014-04-08 11:45:34,292 ERROR [org.jboss.ejb3.tx2.impl.CMTTxInterceptor] (PantherQuartzScheduler_Worker-70) javax.ejb.EJBTransactionRolledbackException: org.hibernate.exception.GenericJDBCException: Cannot open connection
2014-04-08 11:46:06,692 ERROR [org.apache.catalina.core.ContainerBase] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Exception invoking periodic operation: : java.lang.OutOfMemoryError: Java heap space

2014-04-08 11:48:46,596 ERROR [org.apache.catalina.core.ContainerBase] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Exception invoking periodic operation: : java.lang.OutOfMemoryError: Java heap space

2014-04-08 11:49:41,141 ERROR [org.hibernate.util.JDBCExceptionReporter] (PantherQuartzScheduler_Worker-4) Unable to get managed connection for jdbc/com/avaya/mgmt/avSysDB; - nested throwable: (javax.resource.ResourceException: Unable to get managed connection for jdbc/com/avaya/mgmt/avSysDB)
2014-04-08 11:49:41,142 ERROR [org.jboss.ejb3.tx2.impl.CMTTxInterceptor] (PantherQuartzScheduler_Worker-4) javax.ejb.EJBTransactionRolledbackException: org.hibernate.exception.GenericJDBCException: Cannot open connection
[root@aka1smgr ~]#

Cause

It is always recommended to run SMGR and ASM at the same levels (or patch specified versions). Anytime cross version servers are running, there will be expected limitations of operation. Obviously the new enhancements and fixes in the SMGR will not work when running older versions of ASM.

  • SMGR version  : 6.3SP2, which is 6.3.2.4.1399.
  • SM Version 6.3.0.0.630039

or other different versions.

  • SMGR version  : 6.3.8
  • SM Version 6.3.16

 

Solution

Jboss needs to be running in order for ASM to communicate with SMGR to establish trust and replicate the data.  Make sure the box is reachable and that all services are up and running. "service jboss restart" may be needed.

[root@aka1smgr ~]# service jboss restart
Perform cleanup ....
Stopping System Manager JBoss - PID: 3337
.............................................
Stopped System Manager JBoss
Starting System Manager JBoss
.
Service started successfully - PID: 873
[root@aka1smgr ~]#

and later perform the download 

Session Manager 6.3 SP2 Installer ISO image (ASM 6.3.2.632023)

 from the link below:

https://plds.avaya.com/poeticWeb/avayaLogin.jsp?ENTRY_URL=/esd/viewDownload.htm&DOWNLOAD_PUB_ID=SM000000049

Additional Relevant Phrases

El cliente no puede iniciar sesión en la interfaz web SMGR, utilización de la CPU 101,3%, mem 71,1 por mandato JAVA, conexión a ACM no funciona. las llamadas entrantes a ACM (SM1) que no funcionan correctamente cannot access web interface of System Manager SMGR Additional Relevant Phrases SMGR web gui not working

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