ASM: Aura Session All calls from a Session Border controller SBC are failing after an upgrade from Manager ASM 6.1 to ASM 6.3.x.


Doc ID    SOLN248256
Version:    7.0
Status:    Published
Published date:    16 Nov 2018
Created Date:    09 Apr 2014
Author:   
Donald Ryan
 

Details

ASM:  Aura Session All calls from a Session Border controller SBC are failing after an upgrade from Manager ASM 6.1 to ASM 6.3.x.

Problem Clarification

Background: Avaya ASM 6.3.x introduces a new SIP stack, and as part of this additional features are included in the SIP messaging sequence known as headers.  The addition of these SIP headers increases the overall size of a the SIP message.

Per RFC 3261 section 8.2.2 under Header Inspection:  If a UAS does not understand a header field in a request ( this is, the header field is not defined in this specification or in any supported extension), the server MUST ignore that header field and continue processing the message.   A UAS SHOULD ignore any malformed header fields that are not necessary for processing requests.

Based on traces taken at the Acme Session Border controllers, neither the Avaya Session Manger (ASM) nor the ACME Session Border Controllers (SBC)’s were at fault.

Traces at the Acme SBC showed no response to messages sent from the SBC to the SIP carrier. 

Call was eventually canceled by the SIP service provider, most likely because after the carrier sent the initial invite the carrier never recieved the 100 trying, 18x message, or 200 OK message, as these messages, depending on call flow may have been greater than the 1500 byte MTU size and therefore dropped by the public carrier network after the SBC but prior to making to the SIP service provider.

Cause

Certain SIP messages were being dropped by Verizon, the SIP trunk provider.  We identified that UDP SIP messages greater than ~1500bytes in size sent from the Acme SBC would never get a reply from the Verizon SIP service provider.

The Maximum Transmission Unit (MTU) is the largest number of bytes an individual datagram can have on a particular data communications link. When encapsulation, encryption or overlay network protocols are used the end-to-end effective MTU size is reduced. Frequently, links between enterprise routers and the upstream ISP routers only support 1500-byte MTU.

 

Solution

Solution 1: The customer implemented rules to remove some of the additional SIP headers (those which are used for Avaya proprietary features and as such would not be used by the Verizon services) thus reducing the size the SIP packets less then Verizon’s threshold.

Multiple successful test calls were made after this change (prior, we had a 100 failure rate).

While the removing the additional headers was successful, Avaya cautions that this may be costly ( in terms of resources ) to the SBC’s and therefore the customer should verify the resolution with Acme before proceeding.

Solution 2:  Verizon SIP service provider is using UDP SIP which does not allow fragmentation of packets.  If the service provider supports SIP TCP or SIP TLS both of these protocols support fragmentation of packets greater than 1500 bytes.  Customer and SIP service provider could implement a TCP version of SIP. 

Avaya proprietary headers can be safely removed for outgoing packets towards the carrier.  Some of these are:

P-location
P-AV-Message-Id
AVGlobal
Accept-Language
Alert-Info
AV-Correlation-ID
Endpoint-View
History-Info
P-AV-Message-Id
P-Asserted-Identity
P-Charging-Vector
P-Location
Server
 

Attachment Description

Page 8 , 76-77 remove the AV-Correlation-ID from Invite via the SBC

Attachment File

3e6a5bb3-17cc-4611-98c3-5d1b55b9d44b.pdf
6MB • 18 minute(s) @ 56k, < 1 minute @ broadband


Additional Relevant Phrases

Packets Too Large, Calls dropping due to packet Size

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