ACME SBC - Avaya CM (via SM) getting error "SIP/2.0 483 Too Many Hops"


Doc ID    SOLN251036
Version:    6.0
Status:    Published
Published date:    01 Jun 2018
Created Date:    03 Jun 2014
Author:   
pcanonce
 

Details

Inbound call from ACME SBC to CM is failing / getting disconnected.

System Details:

CM 6.2
SM
Far-end is ACME SBC

Problem Clarification

Issue is when ACME SBC placed an inbound call to CM (via SM) and the user is not answering after the call covers to VMM it is getting disconnected. But when the user on CM answers the call then there is no issue.

Cause

SIP trace shows error -- SIP/2.0 483 Too Many Hops

The initial invite from ACME SBC to Avaya SM has Max-Forward of 4.

Then, SM will forwards the INVITE to CM / CLAN. Take note that the Max-Forward
now is 2. What happen is SM100 will forward the INVITE to SM (this is another IP
and considered another sip entity) and the max-forward now is 3. Then SM will send
back the INVITE to SM100 once again with max-forward of 2.

Now, we know that SM100 will forward this INVITE again to CM with max-forward of 1.

Considering the user didn’t pick-up, CM will then forward the INVITE back to SM
with max-forward of 0. Since max-forward now is 0, there’s no way SM can forward
the INVITE to VM.

 

Sample trace:

--------------------------------------------------------------------------------
       *10.10.10.10*                                                           
                   11.11.11.11                                               
--------------------------------------------------------------------------------
10:47:39.643 |--INVITE-->| (726) T:1234566399 F:9876549334 U:1234566399        
10:47:39.646 |<--Trying--| (726) 100 Trying                                    
10:47:39.658 |<--Too Man-| (726) 483 Too Many Hops                             
10:47:39.658 |----ACK--->| (726) sip:[email protected]                     

10:/----------------------------------------------------------------------\    
10:|INVITE sip:[email protected] SIP/2.0                               |    
10:|From: "OUTSIDE CALLER" <sip:[email protected]>;tag=80d4da2640f3e51|    
10:|935c5635585900                                                        |    
   |To: <sip:[email protected]>                                        |
   |Call-ID: 80d4da2640f3e51945c5635585900                                |
   |CSeq: 1 INVITE                                                        |
   |Max-Forwards: 3
 

Solution

ACME SBC needs to increase the Max-Forward. As per RFC the (rfc3261#section-8.1.1.6) max-forward should be 70.

Additional Relevant Phrases

EC500 server not working for calls originating from the outside network

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