AACC 6.4 SP13 : rptadmin.exe stops working, and no scheduled reports will run until a user closes the program.


Doc ID    SOLN254860
Version:    2.0
Status:    Published
Published date:    27 Feb 2018
Created Date:    13 Aug 2014
Author:   
Alan Perry
 

Details

The ReportAdmin stops working, and displays an error on the desktop. The error states "ReportAdmin has stopped working"



The problem details show the following:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: rptadmin.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 537f4c5f
Problem Signature 04: Reporting.Core
Problem Signature 05: 1.0.0.0
Problem Signature 06: 537f4c36
Problem Signature 07: a4
Problem Signature 08: 0
Problem Signature 09: System.StackOverflowException
OS Version: 6.1.7601.2.1.0.274.10
Locale ID: 1033
Additional Information 1: ca4f
Additional Information 2: ca4fcaaf2ad666170b153f79a8b078f3
Additional Information 3: dfab
Additional Information 4: dfabad27a5cda219a87b0522bb8d1064

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Problem Clarification

Scheduled Historical Reports are triggering the error "Report Admin has stopped working" warning

Application events has:
Error 08/11/2014 12:55 Application Error 1000 -100 "Faulting application name: RptAdmin.exe, version: 1.0.0.0, time stamp: 0x537f4c5f
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc00000fd
Fault offset: 0x00456828
Faulting process id: 0x251c
Faulting application start time: 0x01cfb59e222f94e7
Faulting application path: D:AvayaContact CenterManager AdministrationAppsReportingHistoricaldllRptAdmin.exe
Faulting module path: unknown
Report Id: 608a9872-2191-11e4-9beb-00255c3d7c94"

This event Appears to occur approximately the same time when the error is displayed on the server desktop. After this, Application Events shows several events indicating that scheduled reports have run successfully, however none of the reports run during this time are delivered to the reporting folder.

When the "Close the program" button is clicked to clear the error, Application Events shows:
Information 08/11/2014 13:07 Windows Error Reporting 1001 None "Fault bucket , type 0
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: rptadmin.exe
P2: 1.0.0.0
P3: 537f4c5f
P4: Reporting.Core
P5: 1.0.0.0
P6: 537f4c36
P7: a4
P8: 0
P9: System.StackOverflowException
P10:

Attached files:

These files may be available here:
C:UserssysadminAppDataLocalMicrosoftWindowsWERReportArchiveAppCrash_rptadmin.exe_e5beac66372590375d78ea77843269a48e9edf_56bfe271

Analysis symbol:
Rechecking for solution: 0
Report Id: 608a9872-2191-11e4-9beb-00255c3d7c94
Report Status: 0"

CCMA_DisplayReport has

2014-08-08 09:02:01.492-07:00 CCMADisplayReport 21 0 Debug HRReportViewerPresenter DisplayErrorDetailsFromInput Application error: Error = Failed to get report details, Additional Details = Please close this window and try again. If the problem persists, contact your Administrator.

Cause

The CreateHRReportDetails method of HRReportDetailsFactory class calls itself and it causes stack overflow exception.
 

Solution

Design Support has provided AvayaAura_CCMA_6.4.213.303 for this issue.

Attachment File


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