CM EC500 - Setting call number type in off-pbx configuration set for EC500 to "pbx" does not work over SIP trunks


Doc ID    SOLN255226
Version:    3.0
Status:    Published
Published date:    03 Mar 2020
Created Date:    21 Aug 2014
Author:   
Pablo Perremuto
 

Details

Issue noticed in CM 6.3 SP6

Problem Clarification

Calling number style set to "PBX" in configuration set for EC500 calls should send extension digit length as the calling party info instead of what may be configured on the private or public table, most commonly 10 or 11 digits .  This does work for ISDN trunks, but not when going over SIP trunks.  In other words, if the calling extension is 1234, the SIP FROM and PAI headers should show [email protected]. Instead of this, these headers were being populated as [email protected] causing the user receiving the EC500 call to see the 10 or 11 digit number instead of the extension as intended.

Call flow for this would be: Ext A  calls Ext B, where this last extension B has the EC500 feature enabled.   Cell phone would display as the calling number the 10 or 11 digit number instead of the extension corresponding to ext A.

Cause

Tier4 confirmed this issue is present if  "Peer server" field on signaling group is set to "SM". If this field is set to "Other", then the issue is not present.  MR # defsw141203 was raised for this issue.

Solution

Apply any patch containing MR defsw141203 when released for GA.

Additional Relevant Phrases

EC500 vs. SIP trunks

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