Interaction Center: Chat customer gets "Error in connecting to the server. Please quit." or "System is out of service" error.


Doc ID    SOLN255390
Version:    7.0
Status:    Published
Published date:    11 Sep 2017
Created Date:    25 Aug 2014
Author:   
rrinehart
 

Details

IC version: IC 7.X.X

Problem Clarification

When trying to launch a chat session to an instance of Interaction Center, the end user sees a "Error in connecting to the server. Please quit." or "System is out of service"/Outside users getting Internal Service Error 500 in their chat client.

These are two of the most commonly reported errors coming from IC Chat customers.  Either one indicates a problem on the server side.

Cause

It's helpful to know the chat routing process in order to understand where in the process a failure will cause one of the errors.  At a very high level here is how a chat is routed through the IC system:

Customer browser > Web server > ICM > ICM Bridge (Attribute Server) > IC VESP Servers

When the customer requests a chat session, the request is sent from their browser to the web server.  The web server (via the Tomcat JSP engine) sends the request to the ICM (the IC Chat Server).  The ICM communicates to the rest of the IC system via the ICM Bridge, which is hosted by the IC Attribute Server.

If the ICM is down or unreachable, the customer will see the chat start to launch, but then stop with the error: "Error in connecting to the server. Please quit." 

If the ICM is functional but the ICM Bridge is not, the customer will see the chat start to launch, but then stop with the error: "System is out of service." 

(Note that the specific wording of these messages comes from properties set in MultiTenant Administration, and can be changed if desired.  Out of the box, "Error in connecting to the server. Please quit." comes from the property chat.phrases.IccCommon.initerror. "System is out of service"  comes from the property chat.phrases.OutOfService.)

Solution

The first thing to check is that these services are up and running and properly configured.

Occasionally the connection between the ICM and ICM Bridge will get corrupted or broken.  In this case you will see that the Attribute Server is running, but customers will still see the  "System is out of service" error.  This can usually be corrected by stopping and restarting the Attribute Server

Verify 'website' Account is not locked . In case its locked it will generate the same issue  . Reset the account password and update the same in config tool . followed with Attribute  ,Comhub ,ICM service restart .

Additional Relevant Phrases

IC 7.x : Chat service is completely down.

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