CMS ACD link down after the server rebooted


Doc ID    SOLN257426
Version:    5.0
Status:    Published
Published date:    08 Feb 2021
Created Date:    06 Oct 2014
Author:   
Dileep Karichery
 

Details

ACD link down after the power outage
# pkginfo -x cms
cms Avaya(TM) Call Management System
(sparc) r14.1aa.h
r3aexfl# uname -a
SunOS r3aexfl 5.9 Generic_122300-16 sun4u sparc SUNW,Netra-210

Problem Clarification

CMS ACD link down after the server reboot due to power outage or quarterly reboot

Cause

When the cms was booted after the power outage, init read the S99route file that has a special route ( route add host switch1 r3amefl_1 -ifp bge1 ) that sends the switch traffic to bge1. But as the switch(PBX) was configured for bge0, the link traffic could not be sent

(r3amefl)-(root2)=# netstat -nr

Routing Table: IPv4
  Destination           Gateway           Flags  Ref   Use   Interface
-------------------- -------------------- ----- ----- ------ ---------
x.x.x.202                 x.x.x.210        UGH       1      0  bge1
172.31.0.0             x.x.x..209        U         1     12  bge0
172.31.0.0            x.x.x..210        U         1      0  bge1
224.0.0.0              x.x.x..209        U         1      0  bge0
default              172.31.64.193        UG        1      6
127.0.0.1            127.0.0.1            UH        2   1780  lo0
 

Traffic from cm (x.x.x.202) is trying to send data to bge0 (x.x.x.209). but the cms has a route that says send all traffic from (x.x.x.202) to (x.x.x.210) but it can't. CM is configured to send to that through (x.x.x.209)



Sun Feb  7 09:37:33 [00] SESS WSA timeout, retrying...
Sun Feb  7 09:37:43 [00] TCP  client connect timed out
Sun Feb  7 09:38:02 [00] SESS WSA timeout, retrying...
Sun Feb  7 09:38:12 [00] TCP  client connect timed out
Sun Feb  7 09:38:31 [00] SESS WSA timeout, retrying...
Sun Feb  7 09:38:41 [00] TCP  client connect timed out
Sun Feb  7 09:39:00 [00] SESS WSA timeout, retrying...
Sun Feb  7 09:39:10 [00] TCP  client connect timed out
Sun Feb  7 09:39:29 [00] SESS WSA timeout, retrying...
Sun Feb  7 09:39:39 [00] TCP  client connect timed out
 

Solution

Removed the route from S99route file - route add host switch1 r3amefl_1 -ifp bge1

()-(root2)=# route delete 172.31.64.202 172.31.64.210
delete host 172.31.64.202: gateway 172.31.64.210

()-(root2)=# netstat -nr

Routing Table: IPv4
  Destination           Gateway           Flags  Ref   Use   Interface
-------------------- -------------------- ----- ----- ------ ---------
172.31.0.0           x.x.x..209        U         1     32  bge0
172.31.0.0           x.x.x..210        U         1      0  bge1
224.0.0.0            x.x.x..209        U         1      0  bge0
default              172.31.64.193        UG        1     12
127.0.0.1            127.0.0.1            UH        2   4926  lo0
 

 

And also renamed S99route so the server would not read the route command during next reboot and modify the routing table

ACD Link down after reboot can also happen when the ACD is no longer being used, and data collection was turned off on the ACD before reboot.  In this case, just turn data collection for that ACD off.


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