SMGR: Unable to pull software downloads from plds.avaya.com using SUM tool


Doc ID    SOLN258302
Version:    4.0
Status:    Published
Published date:    25 Mar 2019
Created Date:    22 Oct 2014
Author:   
wendeborn
 

Details

System Manager Unable to pull software downloads from plds.avaya.com using SUM tool
/var/log/Avaya/mgmt/sum/debug.log

<11>Sep 19 10:37:48 PSMSYSD01.dev.manulifeusa.com SUM[4256]: -04:00 2014 595 1 com.avaya.sum | 0 com.avaya.common.eps.logging.IptcmCommonLogger Product file: 00.5.742.0-18293.tar.gz is not available on PLDS or PLDS id is null
<11>Sep 19 10:37:48 PSMSYSD01.dev.manulifeusa.com SUM[4256]: -04:00 2014 597 1 com.avaya.sum | 0 com.avaya.common.eps.logging.IptcmCommonLogger Product file: 00.5.742.0-18434.tar.gz is not available on PLDS or PLDS id is null
<11>Sep 19 10:37:48 PSMSYSD01.dev.manulifeusa.com SUM[4256]: -04:00 2014 600 1 com.avaya.sum | 0 com.avaya.common.eps.logging.IptcmCommonLogger Product file: 01.1.628.7-11640.tar.gz is not available on PLDS or PLDS id is null

Problem Clarification

Not available on PLDS or PLDS id is null

Cause

Customer firewall blocking access; in order to download files from PLDS, the SMGR has to be able to access multiple Avaya sites.

 

 

 

Solution

Open up access on customer firewall for:

1.      ftp.avaya.com            135.11.22.85
2.      plds.avaya.com        135.11.53.85 on port 443*
3.      pldsxml.avaya.com  135.11.53.86 on port 443*
The actual file downloads come from:
1.      downloads.dlavaya.com  on port 80
2.      downloads.avaya.com  on port 80
The IP addresses for these sites so far are:
104.71.76.235, 104.71.92.207, 104.85.230.99, 23.37.3.208, 23.61.49.156, 23.73.156.225, 23.201.87.42, 23.194.48.233, and 135.11.53.83
The bottom line is, that for SUM to work, there are many ways to fail through the customer firewall; if the customer allows TCP connections internal to external, then you are fine; they could add firewall rules to allow anything to *.avaya.com.
Here is a test you can use to validate pldsxml.avaya.com from your PC:
From the SMGR:
Note *: The port matrix guide for SMGR 6.3.8 states port 8443, but packet capture shows port 443.

Additional Relevant Phrases

System Manager SMGR Software Upgrade Management (SUM) tool cannot download files from PLDS

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