IP Office: Server failover is not working. When IP Phones roll to secondary server error message on phones "Feature Buttons Invalid" phones don't work


Doc ID    SOLN259293
Version:    6.0
Status:    Published
Published date:    16 Feb 2021
Created Date:    11 Nov 2014
Author:   
Michael Warford
 

Details

Server failover not working. When IP Phones roll to secondary server error message on phones "Feature Buttons Invalid" phones don't work
 

Problem Clarification

IP Office Server Edition IP phone report "Feature Button Invalid" when failover occurs.

Cause

Test 1
1. Assigned Ext 11256 to primary and had it registered.
2. Ext 11256 has three ext buttons.
3. Primary IPO was taken off line. .
4. Phone registered to Secondary IPO on failover. Auto Create Extension was turned on

Test 2
1. Reconnected Primary server.
2. Rebooted phone at Ext 11256 .
3. Ext 11256 re-registered back to the Primary.
4. Opened up the configuration and removed the three appearance buttons.
5. The phone at Ext 11256 immediately displayed "Button Features Invalid".
6. Applied the working hours user rights "No Buttons1xxx'
7. The phone at Ext 11256 displayed all three SA buttons. .

Test 3

1 Removed the Primary.
2. The phone at Ext 11256 re-registered to the secondary.
3. The phone at Ext 11256 immediately displayed Button Features Invalid.
4. Copied over the user right "No Buttons" to "No Buttons1xxx" in the secondary to match the user rights in the primary.
5 The phone at Ext 11256 buttons were restored.

Test 4
1. Removed the User Rights "No Buttons1xxx" from the Primary and the secondary.
2. The phone at Ext 11256 immediately went into "Button Features Invalid".
3.

Solution

• If the IP phones do not have appearance buttons they will display “"Button Features Invalid".
• IF the IP phone register on failover, they will display “"Button Features Invalid" if the phone from the primary server failover and the Secondary server does not have the same User Rights with the same name as the User Rights in the primary.
• IN order to have the buttons carry over on failover:
o A User Rights must be in the Primary and the Secondary with the same user right name.
o The User Rights can be removed from the Primary and Secondary Server and created in the Solution portion of the Centralized managements. The user right will follow the user both on Failover and Hot desk .
o IN order for the User right in the solutions, the Primary and Secondary server must be rebooted after the changed,.

Attachment File

UserRights.png
25K • < 1 minute @ 56k, < 1 minute @ broadband


Additional Relevant Phrases

Feature Buttons Invalid Cant Dial after phone installation SOLN259293

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