VCM: calls to voicemail messaging intermittently doesn’t recognize DTMF tones


Doc ID    SOLN259447
Version:    2.0
Status:    Published
Published date:    02 Nov 2022
Created Date:    14 Nov 2014
Author:   
kassir
 

Details

CMM messaging intermittent does not recognize DTMF tones on inbound calls from cell user to check voicemail.
DTMF tones intermittently fail about 50% of the times.

Issue began after change from T1 to SIP trunks. 

Problem Clarification

Call flow: call from cell #  to AT&T SIP trunk to Avaya SBC to SM where digits are stripped and 3390 is sent to CMM via H.323.

upgraded to CM 6.3 SP7 but still experiencing intermittent no DTMF tones and only for calls going to CMM VM.

cell caller  ----> DID SIP TG 3 SBC ------> SM -----> digits stripped to 3390 ------ SIP TG3 ---> CM6.3 SP7 ----->  IP trunk 99 to CMM 6.3 SP0.

Cause

G450 gateway Voip parameter settings not correct.

Solution

changed the MG voip-parameter 93 to a value of 50 and this inserts 50 milliseconds of silence between digits.

 
To get a base line, MG SME ran a test by making 10 test calls 7 of which failed.
Then changed the voip parameter setting on all 4 gateways ID 93 value 50. Next made 20 test calls and wasn’t able to get a failure. After the test, went back
into each gateway and saved the settings. 
 
 
This voip-parameter (93 , 50   ) setting will inject a 50ms silence period prior
to each digit, which will increase the separation of the blip and the digit from 30
ms to 80ms, thereby keeping the minimum inter-digit gap clean.
 
Non-defaulted Voip Parameter List
Id(decimal,hex)     Value(decimal,hex)
----------------    -----------------------
      93, 0x005d             50, 0x00000032


G450# voip-parameter
G450# set id 93 value 50
G450# dsp-down <<<<<<<<<<<<G450# exit

If it works , the enter "copy run start" to save the values to flash memory.

It it doesn’t work, or to clear all voip-params:

G450# voip-parameter
G450# clear
G450# dsp-down
G450# exit

Additional Relevant Phrases

Solutions ID: SOLN259447

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