Agent is not able to login into POM 3.0.1


Doc ID    SOLN259650
Version:    3.0
Status:    Published
Published date:    07 May 2020
Created Date:    19 Nov 2014
Author:   
psree
 

Details

POM 3.0.1

Problem Clarification

Agent is not able to login again into POM if the client does not send PacketAck for the response/notification. Agents were not nailed many times in between because agent phone was busy or got no answer.

Cause

Agent was not recovered because the PacketAck was not sent from POM client to POM agent manager. So agent manager was not sending any response to that agent after that. Here we could improve the agent manager behavior as it should not wait for PacketAck forever and should process the next command.

Example Analysis:

 

  Not Nailed:                       
15 Oct 2014 16:03:39,643 AGTLogonRESP###79251###ERROR:noanswer
15 Oct 2014 16:03:39,643 AGTLogonRESP###79251###ERROR:noanswer

15 Oct 2014 16:09:49,237 AGTLogonRESP###79251###ERROR:busy
15 Oct 2014 16:09:49,237 AGTLogonRESP###79251###ERROR:busy  // this came in many times

Nailed:
15 Oct 2014 16:10:12,533 AGTNailupChange               N79251                         1929    2   14      SessionID=NULL8       NailedUp

Calls were present to client twice from agent manager after 16:10, there may be the issue with inisoft if the call was not appeared on agent screen.

15 Oct 2014 16:10:24,407 AGTCallNotify                 N79251                         1935    18  14      SessionID=693311      Progressive5       false5
PacketACK                     C79251                         1935    1   4   true^C
15 Oct 2014 16:10:24,741 AGTGetCustomerDetails         C79251                         999     1   4   6933^C
15 Oct 2014 16:10:24,772 AGTGetCustomerDetails         R79251                         1936    9   0    14      SessionID=693324      ID=11072994;AT=READ_ONLY


15 Oct 2014 16:20:55,679 AGTCallNotify                 N79251                         1950    18  14      SessionID=693411      Progressive5       false5
PacketACK                     C79251                         1950    1   4   true^C
15 Oct 2014 16:20:56,005 AGTGetCustomerDetails         C79251                         999     1   4   6934^C
15 Oct 2014 16:20:56,024 AGTGetCustomerDetails         R79251                         1951    9   0    14      SessionID=693424      ID=15111737;AT=READ_ONLY
 

Solution

A  defensive patch is released to improve the behaviour of the POM agent manager regarding this issue. Kindly contact Avaya technical support for details.

Additional Relevant Phrases

Avaya POM . Users not able to login using the POM client.

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