CM: when customer move the IP phone to a voice vlan and set the vlan on the phone, the PC which connect to the IP phone can no longer get IP from DHCP


Doc ID    SOLN260270
Version:    6.0
Status:    Published
Published date:    20 Jul 2022
Created Date:    02 Dec 2014
Author:   
Jizhen Sheng
 

Details

4621’s and 4610’s  IP Phone they work fine when the phone and PC are on the same data VLAN, but when customer move the phone to a voice vlan and set the vlan on the phone, the PC can no longer pull DHCP from the assigned ports access VLAN. It does appear to work if use static IP on PC however.

Problem Clarification

In previous, customer don't have voice vlan, they just have data vlan. and now they want to split the 46xx IP phone and PC into voice vlan and data vlan, after they add the new voice vlan, the IP phone boot up with data vlan to get the ip address and customer manually set the call server ip address and voice vlan ID on the ip phone and IP phone rebooted and got registered, but the PC which connected to the IP phone can not get the IP address via DHCP.

 

Cause

check the DHCP server settings. customer told me the data vlan id is 225 and voice vlan id is 237. customer only set the SSON 176 for voice vlan, they didn't configure the option 176 on the data vlan, and the parameter for option 176 on voice vlan 237 is incorrect like below:
MCIPADD=10.242.157.10,10.242.128.10,MCPORT=1719,L2Q=225,L2QVLAN=237,TFTPSRVR=10.239.32.176

I requested customer add option 176 to data vlan 225 with parameter:
MCIPADD=10.242.157.10,10.242.128.10,MCPORT=1719,L2Q=1,L2QVLAN=237,TFTPSRVR=10.239.32.176
changed the option 176 in voice vlan 237 with parameter:
MCIPADD=10.242.157.10,10.242.128.10,MCPORT=1719,TFTPSRVR=10.239.32.176

After that, customer reboot the IP phone, things get worse, the IP phone can not get IP address from DHCP and prompt DHCP ACK error. I told customer this is more about the data switch or DHCP server issue, since the option 176 configuration is correct now.



 

 

Solution

We suspect issue is more related to the network, and ask customer take sniffer trace on the IP phone, while they taking sniffer trace, they find that there is a loop in the network, seems there is one IP phone connecting its two ports(one port for ethernet port, one port for PC) with two switch, and it makes a loop. after customer fix this, all the IP phone and PC get UP via DHCP.
 


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy