One-X Agent: User wants to prevent changes by agents to preferences


Doc ID    SOLN265033
Version:    4.0
Status:    Published
Published date:    21 Aug 2017
Created Date:    10 Mar 2015
Author:   
gtefft
 

Details

Customer wants to "grey out" buttons for "Agent Preference" and " System Settings" in Avaya_1X_V2.5 to prevent agents from making changes

Problem Clarification

End users are changing agent settings and customer IT department wants to "grey out" buttons for "Agent Preference" and " System Settings" in Avaya_1X_V2.5 to prevent agents from making changes

Cause

Not a breakage - customer wants to prevent agents from making any changes to the corporate standard One-x deployment

Solution

Most of settings are located under \AppData\Roaming\Avaya\one-X Agent\2.5\Profiles\ \Settings.xml If to set “ReadOnly” attribute to “true”, then corresponding setting will be grayed. Some other settings (like AuxReasonCodes, etc.) can be disabled via other xml files under \AppData\Roaming\Avaya\one-X Agent\2.5\Profiles\ \ folder. For example, if to set ReadOnly=true for “Settings->Login” (see above screenshot), then System Settings -> Login window will look like shown here (settings are not editable):

Attachment File

There is no way to disable.docx
0Bytes • < 1 minute @ 56k, < 1 minute @ broadband


Additional Relevant Phrases

Call center agents are able to swich from Manual to Auto and do not receive calls one-x

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