CMS: How to know which skills were removed from Agent and who has turned off the Data collection on CMS


Doc ID    SOLN268006
Version:    6.0
Status:    Published
Published date:    24 Apr 2018
Created Date:    05 May 2015
Author:   
Dody Peribadi ST
 

Details

Version-Release: All

On 18th March skill number 2135 (BD_CareFusion_en) went live and after that someone removed the skill from agents and did not get any calls till 1st April, need to know who removed the skills of the agents.

Problem Clarification

 

Someone has removed the skill from agents and the skill did not get any calls on the reports, how to know who was removed the skills of the agents.
 
And also customer want to know if there someone's turned  the Data Collection off and put it back On from the CMS side, which log need to be observed?
 
Skill removed from agent daily at same time.

Cause

 

The skill 2135 did not get any calls at all on the CMS report

Solution

 

 

Go to CMS Supervisor menu:
1. Select Tools and then Maintenance.
2. Click on the reports tab and highlight and open Automatic Call Distribution (ACD) Administration Log Report.
3. Select the CMS user-ID's, Date Range, Time of Day, which Automatic Call Distributor and the agent ID of the agent in question and click OK.
4. CMS then generate the report and provide the information about the CMS User ID who was deleted the skills assignment of the agents
 
 
 
 
 
 
And following is the example of our CMS lab tested, if someone's turned the Data Collection Off and put it back On then that will be reflected on this log /cms/env/cms_mon/proc_log , "Data collection stopped and Data collection started"

 

There is no audit tool on CMS to track Users commands and/or CMS application changes. The only way is to use Solaris and check access and PID from users and match information.

 

 

The CMS cannot provide the information on which Skills of the Agent are deleted because by designed the CMS will check who has changed the Agent Skills (instead of deleted the skills) and which agents are changed. However, we can use CMS or CMS Supervisor report to check the log report. Every time when someone's Deleted the Skill assignment for the Agents then the Supervisor user-ID will be reflected on Maintenance ACD Administration log and that will be recorded as "Changed Agent Skills" only. Following is the detail of the log information:

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