ACR : some calls cannot find recording information from ACR


Doc ID    SOLN268290
Version:    2.0
Status:    Published
Published date:    11 May 2015
Created Date:    11 May 2015
Author:   
chengdongzhao
 

Details

User can find in CMS report that there're many calls happened. But from ACR, user can only find several recording.

Problem Clarification

User can find in CMS report that there're many calls happened. But from ACR, user can only find several recording. Some recording can be filter out with station number but cannot filter out with Agent ID.

Cause

There're three reasons below:
1, ACR configuration owner changed; related station “recording owner” changed on Apr 23, but the ACR user does not configure to allow to replay calls for the new owner. 
2, Agent does not login; related call happened for station when agent does not login, thus user cannot filter out related recording with the Agent ID but can filter out with the station number.
3, AES product defect which caused ACR cannot get agent information (User will upgrade AES later). Refer to wi00879662 : Agent Information in GetCallInformation is not provided if Service Observer is involved on the call.

Solution

According to the RCA finding, provide solution below:
1, ACR configuration owner changed: Add the new owner name to ACR user so that the ACR user was allowed to replay calls from the new owner.
2, Agent does not login: Filter out recording by Station number.
3, AES product defect which caused ACR cannot get agent information (User will upgrade AES later). Refer to wi00879662 : upgrade AES to AES 5.2.4 & 6.1.1.


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