CM: Incorrect number will be displayed at called party when calling from Genesys VP over SM and SIP trunk to CM and then to external


Doc ID    SOLN268827
Version:    4.0
Status:    Published
Published date:    02 Jun 2021
Created Date:    20 May 2015
Author:   
Andreas Voigt
 

Details

CM release: vcm-016-03.0.124.0 patch 22098

Problem Clarification

 

Customer has two call scenarios, when they call an external number from an extension of their CM they send 800xxxxxxx to the provider with type of number national, this works fine, shows 0800xxxxxxx at the called party:
 
       <-   CALLING PARTY NUMBER ................................. 8003301000
            | Reference page(s):                P-IV-4-34, B-IV-B-6, A-53, A3
            | 6c=oct1    ie identifier:                  Calling Party Number
            | 0c=oct2    contents length:                                  12
            | 21=oct3    type of number:                             national
            |            numbering plan:ISDN/telphny plan E.164/3 |cv
 
The other call is generated by a Genesys application, comes over SM and SIP trunk to the CM and in this scenario the CM transmits  0800xxxxxxx with type of number unknown, in this scenario the called party gets the Main number of the trunk signalled and not what CM is sending to the provider:
 
<-   CALLING PARTY NUMBER ................................ 08003301000
            | Reference page(s):                P-IV-4-34, B-IV-B-6, A-53, A3
            | 6c=oct1    ie identifier:                  Calling Party Number
            | 0d=oct2    contents length:                                  13
            | 01=oct3    type of number:                         unknown type
            |            numbering plan:ISDN/telphny plan E.164/3 |cv
 

 

Cause

Tandem calling not administered in CM, there you can set the type of call

Solution

 

display tandem-calling-party-num                                Page   1 of   8
                         CALLING PARTY NUMBER CONVERSION
                                 FOR TANDEM CALLS
                            Incoming                                                   Outgoing   Natl                         Outgoing
Any     Any CPN                      Number     Trunk                                 Intl                           Number
Len      Len CPN Prefix          Format      Group(s)     Del               Pfx    Insert            Format
x                    0800                      unk-unk    2                     1                                                      natl-pub
 
Administer this at the customer and your number will be transmitted as it should be. Choose the outgoing trunk as Trunk Group.

Additional Relevant Phrases

SOLN268827

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