CMS r17jb.a


Doc ID    SOLN269869
Version:    1.0
Status:    Published
Published date:    08 Jun 2015
Author:   
shinde6
 

Details

Customer has 2 R17 CMS in HA. one OA server.

 

Problem Clarification

 Customer reported issue that ECH data is missing in OA reported after CMS reboot. They had planned CMS reboot activity for both CMS servers. So ECH data in OA reports was missing for those days

Cause

 CMS couldn't sendout data to OA server. On secondary/HA server we found process was hung and on Primary it was due to reboot of CMS.

Solution

 on the CMS server:
- login as root user
- su - biadmin 
- . /opt/BI/.profile
- pa list - send output
- dcstat -n fwdcmscallhistory -a - send output  check status of service.

<<<<<Send data to OA server manually>>>>>

1. login as root

2. go to "cd /cms/ech_data/archive" >> this folder/directory contains archived files of ECH data which is collected for that date.

3. Determine the desired file.  The file names are in the format YYYYJJJ.Z  or YYYYJJJ.bz2 where YYYY is the year, JJJ is the Julian day the file was created.  '.Z' indicates that the file was compressed with the 'compress' utility.  '.bz2' indicates that the file was compressed with the 'bzip2' utility. As an example, if you are seeking the ECH data files that were created on July 27, 2006 the file name would be 2006209.Z or 2006209.bz2.  The 209  indicates July 28th, the day the archive was created.  You can also look  at the time stamp of the file (with 'ls -lt') to see when it was created. Remember that ECH data files are archived the day following collection.

4. Enter: 2011244.bz2 2011245.bz2

   cp  2006209.Z  ../recovery     # copy the file to the 'recovery' directory)

         OR

   cp  2006209.bz2  ../recovery   # if a .bz2 file

   cd  ../recovery

   uncompress  2006209.Z   # if a .Z file

         OR

   bunzip2 2006209.bz2     # if a .bz2 file

2011244 2011245

   cpio  -ivm  <  2011245         #>>(extract the files from the CPIO archive)

   rm  2006209  

NOTE:  Uncompressing multiple compressed files can result in using up all the free space on the /cms partition and crashing CMS.  Do NOT uncompress more than one compressed file at a time.  If recovering multiple days, uncompress one compressed file, process it, then remove the files in the 'recovery' directory before copying in and uncompressing the next compressed file.

5) The 'recovery' directory will now contain all the binary ECH files that

   where extracted from the compressed CPIO archive file.  These files

   will be named chrXXXX.nnn.  You now need to re-queue the particular file

   or files that you want to be retransmitted.  Note that you may

   unintentionally resend data that is already in the receiving database.

   This should not be a problem since a correctly configured database table

   will simply reject those data records that are duplicates.

 

   You may look at the time stamp of the files with the "ls -lt" command to

   determine which file(s) you desire to requeue.

 

   Enter:  ls -lt | more

   (we'll use the file chr1201.001 as an example)

 

6) To re-queue files:

    To send the file to NICE Analyzer/Explorer, enter:

     cp chr1201.001 /cms/cvx_queue

    To send the file to a 2nd Analyzer/Explorer (or ISM), enter:

     cp chr1201.001 /cms/ism_queue

    For files that are to be converted to ASCII for a custom application,

   enter:  /export/home/pserv/ech/ascii_resend chr1902.452

     OR

     /export/home/pserv/ech/ascii_resend2 chr1201.001

    To send the file to Avaya OA, enter:   /export/home/pserv/ech/OA_resend chr1201.001

    To send the file to Aspect DataMart, enter:  /export/home/pserv/ech/Aspect_resend chr1201.001

 <<<<<In case you face error as below while re-queing data you can restart the history service.>>>>>
Error while performing data push/reque to OA server.

(euc_vcc_cms01)-(Secondary)=# /export/home/pserv/ech/OA_resend chr0001.703
06/01/15 11:10:38 - OA_resend: recovering chr0001 for OA

interface 'ListenerV2' not supported by CRM_BI.root/collect.pkg/fwdcmscallhistory.obj

 

You just go to 

- login as root user
- su - biadmin 
- . /opt/BI/.profile
pa disable cmscallhistory  #then

-  pa enablecmscallhistory    #post this commands try to queu data as mentioned in above step 6.

 

Note: files which are there in /cms/ech_data/recovery folders are cleanout by CMS after midnight. 


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