OneXagent not received UUI 3rd party vendor


Doc ID    SOLN270110
Version:    1.0
Status:    Published
Published date:    26 Jun 2015
Author:   
Juan Gabriel Ayala Cedillo
 

Details

Call flow.

Toll Free number from AT&T routes to hird Party Call center and IVR vendor.
 
Their call flow determines needs to route to our on-site Call Center (via skill number configured )  ATT ISDN trunks Avaya CM version 6.3.0.124.0-21460.
 
They perform an InBand Transfer and Contact via AT&T passing the UUI ( UUI is send by 3rd party application vendor ) This routes to another AT&T toll free number which terminates to our Trunk group 63 ISDN passing DNIS with the UUI information incoming calls arrives to CM and call is received by Avaya OneXagents Fw 2.5.5
Here OneXagent not present incoming UUI send by 3rd party application via ATT ISDN trunk.

Problem Clarification

OneXagent not received UUI 3rd party vendor.

Cause

CM mismatch configuration.

CM configuration not working.

display trunk-group XX ( incoming trunk ) Page 2 of 21

Group Type: isdn

TRUNK PARAMETERS

..

Supplementary Service Protocol: b

display trunk-group XX Page 3 of 21

TRUNK FEATURES

..

Outgoing Channel ID Encoding: preferred UUI IE Treatment: shared

 

Solution

Reconfigure trunk with next values.

display trunk-group XX ( incoming trunk ) Page 2 of 21

Group Type: isdn

TRUNK PARAMETERS

..

Supplementary Service Protocol: a   >>> It is the correct value >>>

display trunk-group XX Page 3 of 21

TRUNK FEATURES

..

Outgoing Channel ID Encoding: preferred UUI IE Treatment: service-provider  >> Correct value >>

After configuration done OneXagent receives correct UUI.


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