one-X Agent : Make call fails, calls get dropped.


Doc ID    SOLN270192
Version:    5.0
Status:    Published
Published date:    08 Apr 2020
Created Date:    12 Jun 2015
Author:   
Dan Morrissey
 

Details

Remote agent using Avaya one-x Agent at home with landline keeps getting disconnected when they try to make a call.

Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - LinkRecoveryProgressEvent
Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - LinkRecoveryProgressEvent

OneXAgentUI.MainWindow Exception:
WorkItem_AddVoiceInteraction failed;Avaya.OneXAgent.OneXAgentException: Command failed [action=MakeCall(uri=), statusCode=RC_TIMEDOUT] ---> Avaya.OneXAgent.CMService.Utils.PhoneServiceException: Command failed [action=MakeCall(uri=), statusCode=RC_TIMEDOUT]

Problem Clarification

one-X Agent is losing it's link, resulting in timeouts and link recovery events evident in the logs..

Cause

We are receiving session ended events and timeouts from the server intermittently. There were no ERRORS in the log files. The worker was using a wireless connection, and the "landline" was a service provider VOIP phone that the customer was not aware of.

Solution

NETWORK Related.

The user was working wirelessly, and the issue only  started occurring after the service provider's switch to one that uses a VOIP phone as a "landline"


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