Endpoint: Unable to record calls initiated by E129 SIP phone


Doc ID    SOLN271801
Version:    4.0
Status:    Published
Published date:    08 Apr 2016
Created Date:    13 Jul 2015
Author:   
aa1
 

Details

Avaya E129 SIP phone: 1.2A ,

Avaya Contact Recorder: cscm-12.0-1patch_12.0-sp0-0132

Unable to record E129 sip endpoints on Avaya ACR

Problem Clarification

Outbound and Inbound calls generated from Avaya E129 phone does not trigger recording. When checking the ACR (Avaya Contact Recorder), CTI (Computer Telephony Interface) event triggered but no recording is happening. It seems as if the DMCC is not being conferenced in on the call. 
 

Cause

Avaya E129 does not support Avaya Aura Advanced SIP Telephony (AST) features, because E129 is a basic SIP phone. Product details can be found here:  http://www.avaya.com/usa/documents/e129-sip-deskphone---sme7492.pdf. (supports basic, generic, open-standards SIP features above (no Avaya Aura® Advanced SIP Telephony features are supported).  Since ACR (Avaya Contract Recorder) communicates with the AES (Application Enablement Services) and since AES requires extended feature set from the endpoints, calls initiated by E129 will not be able to be recorded. An Avaya SIP phone that supports AST is needed in such a scenario for the recording to work.

 Unfortunately this is working as designed. The E129 being basic SIP phones were not designed to be call recorded. Our recommendation is to use one of the 96xx SIP series phones that do support AST features.

Solution

Use Avaya 96xx phones instead


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