AES 6.3.3: SMS List Agent Query Is Returning "Invalid Fields"


Doc ID    SOLN272874
Version:    5.0
Status:    Published
Published date:    24 Oct 2024
Created Date:    03 Aug 2015
Author:   
Chris Barnhart
 

Details

Customer has reported that when using the SMS Query tool on the newly upgraded AES 6.3.3, it is returning less information, and generating an “Invalid Fields” error in the “Response section of the Web Page.  The missing fields are TN, Coverage Path, Security Code and Auto Answer.

 

***********************************************************************

Application Enablement Services

***********************************************************************

Version: 6.3.3.3.10-0

Server Type: OTHER

Offer Type: VIRTUAL_APPLIANCE_ON_SP

Virtual Machine Information - AES

Software Update Revision: 6.3.3.3.10-0

System Platform Version: 6.3.6.01005.0

***********************************************************************

Operating System Version: Linux 2.6.18-371.12.1.AV2.domU.el5xen

 

************* Patch Numbers Installed in this system are  *************

LSU-6.3.3-1

LSU-6.3.3-2

3

LSU-bash-shellshock

***********************************************************************

Use "swversion [-a | --all]" to get a complete list of AE Services RPMS

and Patches/Updates

Below is the error reported in the /opt/mvap/logs/apache/ssl_error.log,

 

[Wed Jul 29 12:26:13 2015] [error] [client 138.XX.xx.XX] PHP_DEBUG: Wed Jul 29 16:26:13 2015: Constructing model

[Wed Jul 29 12:26:13 2015] [error] [client 138.XX.xx.XX] PHP_DEBUG: Wed Jul 29 16:26:13 2015: Enabling 'list' model features

[Wed Jul 29 12:26:13 2015] [error] [client 138.XX.xx.XX] PHP_ERR: Wed Jul 29 16:26:13 2015: 1 00000000 0000 Invalid field(s): TN

[Wed Jul 29 12:26:13 2015] [error] [client 138.XX.xx.XX] PHP_DEBUG: Wed Jul 29 16:26:13 2015: Serializing modelChoices

[Wed Jul 29 12:26:13 2015] [error] [client 138.XX.xx.XX] PHP: Wed Jul 29 16:26:13 2015: Request: \n<?xml version="1.0" encoding="UTF-8"?>\n<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://xml.avaya.com/ws/SystemManagementService/2008/07/01" xmlns:ns2="http://xml.avaya.com/ws/session"><SOAP-ENV:Header><ns2:sessionID SOAP-ENV:mustUnderstand="1" SOAP-ENV:actor="http://schemas.xmlsoap.org/soap/actor/next">1f882XXxxXXxxXXxxXXxxXXxxXXxxXXxxX</ns2:sessionID></SOAP-ENV:Header><SOAP-ENV:Body><ns1:submitRequest><modelFields><Agent><TN/></Agent></modelFields><operation>list</operation><objectname></objectname><qualifier></qualifier></ns1:submitRequest></SOAP-ENV:Body></SOAP-ENV:Envelope>\n

 

The Below response is missing the TN, Coverage Path, Security Code, and Auto Answer,

 

Response {

  var $result_code = 0

  var $result_data =

'<?xml version="1.0"?>

<result_data>

  <Agent>

    <Login_ID>70.10.05</Login_ID>

    <Name>Agent 7018005</Name>

    <Extension>unstaffed</Extension>

    <Direct_Agent_Skill/>

    <AAS>n</AAS>

    <AUDIX>n</AUDIX>

    <COR>1</COR>

    <Call_Handling_Preference>skill-level</Call_Handling_Preference>

    <Service_Objective>n</Service_Objective>

    <SN/>

    <SL/>

  </Agent>

</result_data>

'

  var $message_text = ''

}

 

Problem Clarification

After upgrading from AES 6.3.0 to 6.3.3, the “Agent List” query used in the SMS Interactive Tool on the AES does not return TN, Coverage Path, Security Code, Auto Answer.  This exact test was performed in the AVAYA lab on an AES 6.3.0, and the older release does in fact return more information,

 

***********************************************************************

Application Enablement Services

***********************************************************************

Version: 6.3.0.1.212-0

Server Type: DELL1950

Offer Type: TURNKEY

 

***********************************************************************

Operating System Version: Linux 2.6.18-308.16.1.el5PAE

 

************* Patch Numbers Installed in this system are  *************

LSU-bash-shellshock

1

***********************************************************************

Use "swversion [-a | --all]" to get a complete list of AE Services RPMS

and Patches/Updates

<Agent>

    <Login_ID>6000002</Login_ID>

    <Name>Larry, Rhonda</Name>

    <Extension>6002002</Extension>

    <TN>1</TN>

    <COR>86</COR>

    <Coverage_Path/>

    <Security_Code/>

    <AAS>n</AAS>

    <AUDIX>n</AUDIX>

    <LCW_Reception/>

    <LWC_Log_External_Calls>n</LWC_Log_External_Calls>

    <AUDIX_Name_for_Messaging/>

    <Hears_Service_Observing_Tone>n</Hears_Service_Observing_Tone>

    <Login_ID_For_ISDN_Display>y</Login_ID_For_ISDN_Display>

    <Port_Extension/>

    <Auto_Answer>acd</Auto_Answer>

    <MIA_Across_Skills>system</MIA_Across_Skills>

    <ACW_Agent_Considered_Idle>system</ACW_Agent_Considered_Idle>

    <Aux_Work_Reason_Code_Type>system</Aux_Work_Reason_Code_Type>

    <Logout_Reason_Code_Type>system</Logout_Reason_Code_Type>

    <Maximum_Time_In_ACW_Before_Logout>system</Maximum_Time_In_ACW_Before_Logout>

    <Direct_Agent_Skill>32</Direct_Agent_Skill>

    <Call_Handling_Preference>skill-level</Call_Handling_Preference>

    <Service_Objective>y</Service_Objective>

    <Direct_Agent_Calls_First>y</Direct_Agent_Calls_First>

    <Local_Call_Preference>n</Local_Call_Preference>

  </Agent>

 

Cause

The SMS utility operates with commands used by the SAT terminal on the CM.  When “list agent” is performed, the query is returned without the TN, Coverage Path, Security Code, and Auto Answer.  The AES version 6.3.3 is pulling the correct information displayed from the SAT terminal.

 

 

 

 

 

Response {

  var $result_code = 0

  var $result_data =

'<?xml version="1.0"?>

<result_data>

  <Agent>

    <Login_ID>70.10.05</Login_ID>

    <Name>Agent 7018005</Name>

    <Extension>unstaffed</Extension>

    <Direct_Agent_Skill/>

    <AAS>n</AAS>

    <AUDIX>n</AUDIX>

    <COR>1</COR>

    <Call_Handling_Preference>skill-level</Call_Handling_Preference>

    <Service_Objective>n</Service_Objective>

    <SN/>

    <SL/>

  </Agent>

</result_data>

'

  var $message_text = ''

 

Solution

Working as designed.  A consult to AES CPE revealed that the SMS xml schema had been changed and corrected for AES 6.3.3 to pull the same data as if the command was being run directly in the SAT terminal of the CM.  The workaround for this would be to use “Display Agent” instead of List Agent.

Additional Relevant Phrases

AES SMS

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