Wrong called/connected party number displayed on E129 SIP Phone


Doc ID    SOLN273000
Version:    1.0
Status:    Published
Published date:    05 Aug 2015
Author:   
Levente Szabo
 

Details

E129: boot 1.0.1.23; core 1.25.2.2; base 1.25.2.7; prog 1.25.2.26 (this is the running fw of the e129)
CM: 6.3.8
SM: 6.3.7

Problem Clarification

Scenario :
E129 calls out via SIP Trunk between CM/SM to C4 Softswitch.
After call is answered , wrong called (connected) number is presented on the phone screen.
 

This problem observed only on E129 phones.
Other phones like 96x1 SIP Phones are working correctly.

The below snippet of trace shows how the connected number changes in the "Contact" header and the extra prefix, in this case: "D50" comes from the far end: Kamnet:

incoming message to SM from Kamnet:


23/07/2015 11:11:34.779 -->

--------------------

SIP/2.0 183 Session Progress

Call-ID: 04a3991e235e511ade55b6791100

From: "2022 2022" <
sip:[email protected];user=phone>;tag=04a3991e235e5119de55b6791100
To: <
sip:[email protected];user=phone>;tag=9300080565081598636
Content-Type: application/sdp

CSeq: 1 INVITE

Via: SIP/2.0/UDP 10.25.186.2;received=10.25.186.2;rport=5060;branch=z9hG4bK245471471744614-AP;ft=10.25.186.2~13c4,SIP/2.0/UDP 10.25.186.1:15060;rport=15060;ibmsid=local.1418645775849_18322618_18402707;branch=z9hG4bK245471471744614,SIP/2.0/UDP 10.25.186.1:15060;rport;ibmsid=local.1418645775849_18322617_18402706;branch=z9hG4bK269341651156516,SIP/2.0/TLS 10.25.186.2;branch=z9hG4bK04a3991e235e511bde55b6791100-AP;ft=745619;received=10.25.186.2;rport=30963,SIP/2.0/TLS 10.25.186.7;branch=z9hG4bK04a3991e235e511bde55b6791100,SIP/2.0/TLS 172.16.60.230:5061;alias;branch=z9hG4bK1404705389;rport=56327

Contact:  <sip:[email protected]:5060;user=phone>
(…)


Then SM forwards the session progress message to the CM:


23/07/2015 11:11:34.781 <--

--------------------

SIP/2.0 183 Session Progress

P-Asserted-Identity: <
sip:[email protected]>
P-Location: SM;origlocname="location-01001";origsiglocname="location-01001";origmedialocname="location-01001";termlocname="Kamnet";termsiglocname="Kamnet";termmedialocname="Kamnet";smaccounting="true"

P-AV-Message-Id: 1_3

Server: AVAYA-SM-6.3.7.0.637008

Av-Global-Session-ID: 6d139380-3112-11e5-94e0-005056b23566

Allow: ACK, BYE, CANCEL, INVITE, OPTIONS, PRACK, UPDATE

Supported: timer, 100rel

Contact: <sip:[email protected]:5060;user=phone;gsid=6d139380-3112-11e5-94e0-005056b23566>
(…)


Then CM sends it back to SM and then SM to the E129 phone – however
here the called party number is correct again!:

23/07/2015 11:11:34.783 -->

--------------------

SIP/2.0 183 Session Progress

From: <
sip:[email protected]>;tag=492044316
To: <
sip:[email protected]>;tag=04a3991e235e5115de55b6791100
Call-ID:
[email protected]
CSeq: 31 INVITE

Via: SIP/2.0/TLS 10.25.186.2;branch=z9hG4bK678238131853082-AP;ft=738833

Via: SIP/2.0/TLS 10.25.186.1:15061;branch=z9hG4bK678238131853082;rport=48577;ibmsid=local.1418645775849_18322615_18402704

Via: SIP/2.0/TLS 10.25.186.1:15061;branch=z9hG4bK918025033604305;ibmsid=local.1418645775849_18322614_18402703

Via: SIP/2.0/TLS 10.25.186.2;branch=z9hG4bK1404705389-AP;received=10.25.186.2;rport=30963;ft=750506

Via: SIP/2.0/TLS 172.16.60.230:5061;alias;branch=z9hG4bK1404705389;rport=56327

Supported: histinfo,join,replaces,sdp-anat,timer

Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,INFO,UPDATE

Contact: <sip:90509165768@10.25.186.7:5061;transport=tls>;+avaya-cm-keep-mpro=no
Record-Route: <sip:10.25.186.7:5061;transport=tls;lr>
Record-Route: <
sip:[email protected];transport=tls;lr>
Record-Route: <
sip:10.25.186.1:15061;transport=tls;lr;ibmsid=local.1418645775849_18322614_18402703>
Record-Route: <
sip:[email protected];transport=tls;lr>
Server: Avaya CM/R016x.03.0.124.0

(…)


23/07/2015 11:11:34.785 <--

--------------------

SIP/2.0 183 Session Progress

P-Asserted-Identity: <
sip:[email protected]>
P-Location: SM;origlocname="location-01001";origsiglocname="location-01001";origmedialocname="location-01001";orighomelocname="Home";termlocname="Home";termsiglocname="Home";termmedialocname="Home";smaccounting="true"

Server: Avaya CM/R016x.03.0.124.0 AVAYA-SM-6.3.7.0.637008

Av-Global-Session-ID: 6d139380-3112-11e5-94e0-005056b23566

Record-Route: <
sip:10.25.186.7:5061;transport=tls;lr>
Record-Route: <
sip:[email protected];lr;transport=TLS>
Record-Route: <
sip:10.25.186.1:15061;transport=tls;lr;ibmsid=local.1418645775849_18322614_18402703>
Record-Route: <
sip:[email protected];lr;transport=TLS>
Contact: <sip:[email protected]:5061;transport=tls;gsid=6d139380-3112-11e5-94e0-005056b23566>;+avaya-cm-keep-mpro=no

However, later on Kamnet sends OK to the INVITE message, now with wrong called party number:


23/07/2015 11:11:36.833 -->  


SIP/2.0 200 OK

Call-ID: 04a3991e235e511ade55b6791100

From: "2022 2022" <
sip:[email protected];user=phone>;tag=04a3991e235e5119de55b6791100
To: <
sip:[email protected];user=phone>;tag=9300080565081598636
Content-Type: application/sdp

Session-Expires: 1200;refresher=uac

CSeq: 1 INVITE

Via: SIP/2.0/UDP 10.25.186.2;received=10.25.186.2;rport=5060;branch=z9hG4bK245471471744614-AP;ft=10.25.186.2~13c4,SIP/2.0/UDP 10.25.186.1:15060;rport=15060;ibmsid=local.1418645775849_18322618_18402707;branch=z9hG4bK245471471744614,SIP/2.0/UDP 10.25.186.1:15060;rport;ibmsid=local.1418645775849_18322617_18402706;branch=z9hG4bK269341651156516,SIP/2.0/TLS 10.25.186.2;branch=z9hG4bK04a3991e235e511bde55b6791100-AP;ft=745619;received=10.25.186.2;rport=30963,SIP/2.0/TLS 10.25.186.7;branch=z9hG4bK04a3991e235e511bde55b6791100,SIP/2.0/TLS 172.16.60.230:5061;alias;branch=z9hG4bK1404705389;rport=56327

Contact:  sip:[email protected]:5060;user=phone
(…)

Which remains the same till it is sent to the E129 endpoint:


23/07/2015 11:11:36.843 <--


SIP/2.0 200 OK

P-Location: SM;origlocname="location-01001";origsiglocname="location-01001";origmedialocname="location-01001";orighomelocname="Home";termlocname="Home";termsiglocname="Home";termmedialocname="Home";smaccounting="true"

Server: Avaya CM/R016x.03.0.124.0 AVAYA-SM-6.3.7.0.637008

Av-Global-Session-ID: 6d139380-3112-11e5-94e0-005056b23566

Session-Expires: 1200;refresher=uas

Require: timer

Record-Route: <
sip:10.25.186.7:5061;transport=tls;lr>
Record-Route: <
sip:[email protected];lr;transport=TLS>
Record-Route: <
sip:10.25.186.1:15061;transport=tls;lr;ibmsid=local.1418645775849_18322614_18402703>
Record-Route: <
sip:[email protected];lr;transport=TLS>
P-Asserted-Identity: <
sip:D500509165768@192.168.180.1>
Contact: "D500509165768@" <sip:[email protected]:5061;transport=tls;gsid=6d139380-3112-11e5-94e0-005056b23566>;+avaya-cm-keep-mpro=no

Cause

While we can wonder why the far end sends the "D50" prefix and could ask user to try and correct it there, chances are an E129 configuration parameter change may help.

Solution

Ask user to check the E129 configuration file and look out for parameter: P2324

As per "Administering Avaya E129 SIP Deskphone" document:
Parameter P2324:
Specifies whether to display caller ID. Assign one of the following values to
this parameter:
• 0: Auto
• 1: Disabled
• 2: From Header
Default value: 0

So if this is other than 2, try to change it to 2 and check if that helped. It did fix the problem for the example described above in this article.


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