Virtual Services Platform: System Platform (VSP) service pack update R6.3.5 to R6.3.7/6.4.0 Fails.


Doc ID    SOLN273203
Version:    15.0
Status:    Published
Published date:    23 Aug 2019
Created Date:    10 Aug 2015
Author:   
curry1
 

Details

 Unable to update VSP from (example here)  6.3.5 to 6.3.7 or 6.4 system upgrade failed to activate dom0 image.> Within logs can see: 

 

00:28:14 Making sure that enough disk space is available. Complete 100 0s 

00:28:14 Verifying version and manifest information for Console domain and Domain-0 which are being upgraded from SP version: 6.3.6.01005.0 to: 6.3.7.0.05001 Complete 100 0s 

00:28:15 Downloading the common image. Complete 100 0s 

00:28:19 Downloading the Domain-0s image. Complete 100 0s 

00:28:21 Downloading the console domains image. Complete 100 0s 

00:28:25 Preparing to install console domains upgrade image. Complete 100 0s 

00:28:32 Installing cdom upgrade image. Complete 100 0s 

00:29:08 Installing dom0 upgrade image. Complete 100 0s 

00:30:11 Prepare to start new Domain-0. Complete 100 0s 

00:30:14 Preparing to start the new console domain. There will be a need to relogin. Complete 100 0s 

00:30:19 Backing up System Platform. Complete 100 0s 

00:30:58 Upgrade failed to activate dom0 image Failed 0 0s  <-- Here's the error

 Reboot Domain-0. Not Started 0 18m 0s *

 Wait for user input to Commit or Rollback upgrade. Not Started 0 0s *

 Commit or Rollback Not Started 0 5s *

00:28:23 Releasing CD/DVD/USB devices. Complete 100 0s 

Problem Clarification

System Platform service pack update fails. Consistently, attempting to update DOM0 image fails too

Cause

Isolated issue to incorrect devices is attempting to be accessed.
System is looking to load from USB.., in which is not supported via VSP 6.3.7
release notes (June-2015 - document#-101011419)
Issue is due to sometime in the past there was a USB device on system and
rebooted, thus remapped the device.map file creating our issue.

This kind of issue's during the installation are related to below:

 1- corrupted ISO image.

2- corrupted DVD while copying.

3- faulty DVD drive or USB connected to S8300.

4- faulty server.

Also sometime upgrade failed due to wrong procedure followed for OVA mounting.

Can you can manually do below steps and try to upgrade :

·         mkdir /tmp/temp/ and copy the iso in to it.

·         mount -o loop vsp-6.4.0.0.17004.iso /tmp/temp

·         cp -R /tmp/temp/* /vsp-template/VSP/

·         umount /tmp/temp

 Also sometime issue observed it manually (copying the files from ISO) too. Can you please do md5sum  of iso file and make sure it match with same mentioned in plds

 

Solution

Via root: Modified (vi edit) device.map file, within /boot/grub/device.map to support c0d0 onto hd0...


[root@sfxdom0cm2 ~]# cat /boot/grub/device.map
(hd0)   /dev/sda          <<<< -- Faulty.., system had a USB stick applied in the past...
(hd1)   /dev/cciss/c0d0

Modify, edit the device.map to be using c0d0 as noted below using the following command (vi /boot/grub/device.map) and then changing the entry to reflect the output below:

[root@sfxdom0cm2 ~]# cat /boot/grub/device.map
(hd0)   /dev/cciss/c0d0

Once completed.., customer was able to now successfully update to SP 6.3.7...

Refer to MR - wi00893044 as software error.

 

So I would recommend:

1- use different ISO image.

2- new DVD.

3- different DVD drive or USB and make sure if DVD is used its fully charged.

 

4- If all above fail then you need to Replace the S8300 server.

Additional Relevant Phrases

System Platform getting Upgrade failed to activate dom0 image Failed when upgrading to 6.3.7 SOLN273203 System Platform unable to communicate with cd/dvd device boot/grub mapping

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy