CM - Call drops when using Genesys UUSP softphone app and it's transfer tree function, performing a warm transfer


Doc ID    SOLN274699
Version:    2.0
Status:    Published
Published date:    22 Mar 2016
Created Date:    04 Sep 2015
Author:   
Timothy Ostapchuk
 

Details

User has reported that when an agent attempts to ‘warm transfer’ using Genesys UUSP softphone, the call is dropped.

 

CM:  5.02.1.016.4 – 20445

 

Symptoms/Configuration

 

·         Agent IP phone is registered to either Network Region (NR) 1, 2, or 3

·         Agent Login ID is in a different NR which also shares two Media Gateways (MG)

 

Problem Clarification

Calls drop when trying to warm transfer a call using Genesys transfer tree from UUSP softphone app

Cause

When the agent tries to use warm transfer from the Genesys UUSP softphone app and its transfer tree feature, when the 2nd leg of the call is setting up, it is grabbing a media resource from the same NR X ( from the MGs) and the SIP trunks are unable to negotiate the codec set correctly, giving a codec mismatch denial event. The SIP trunks are set up to only use G.711 and the local MG is using G.729a.

Solution

Separated the agent login id NR from the MGs NR. Left the agent login ids in its current NR and created a new NR for the MGs, so now the agent's IP phone and login id are registering to NR1, 2 or 3 and using media resources from NR1, 2 or 3, as it is designed to do. Now the SIP trunks are negotiating the correct codec set, G.711 and all works correctly now.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy