CMS: Agent summary interval report shows all agent time doubled


Doc ID    SOLN275306
Version:    2.0
Status:    Published
Published date:    18 Sep 2015
Created Date:    16 Sep 2015
Author:   
mjiang
 

Details

Product: CMS 16.3
The site has HA servers.

Problem Clarification

All the time are duplicate from 1:30 to 5:15 interval on Aug 13 for those log in agents.

Cause

Someone is performing data merge on Aug 13 for interval 0130 to 0515. That is the culprit.

The HA log luckily still keep this information:

1347 08/13/2015 14:28:49 - Start ACD 1 data merge between 08/13/2015 0130 and
08/13/2015 0515
1348 08/13/2015 14:28:49 - Start 08/13/2015 ESS data for table hagent, ACD 1
1349 Database selected.
1350 Lockmode set.
1351 PDQ Priority set.
50 Lockmode set.
1351 PDQ Priority set.
1352 56386 row(s) retrieved into temp table.
1353 0 row(s) updated.
1354 27428 row(s) deleted.
1355 28168 row(s) inserted.
1356 27428 row(s) deleted.
1357 28168 row(s) inserted.
1358 Table dropped.
1359 1530 row(s) deleted.
1360 Database closed.
1361 08/13/2015 14:29:29 - Complete 08/13/2015 ESS data for table hagent, ACD
1449 PDQ Priority set.
1450 Database closed.
1451 08/13/2015 14:32:51 - Complete 08/13/2015 ESS data for table haglog, ACD
1
1452 08/13/2015 14:32:51 - Complete ACD 1 data merge between 08/13/2015 0130
and 08/13/2015 0515

thus staff time was counted twice for both main CM data and ESS data during 01:30 to 05:15 interval on Aug 13, this explains why it shows 30 minutes instead of 15minutes. The merge appears improper since it duplicate the time and data. hagent is table to record agent interval information.

Solution

Since this is a large call center, most of your CMS logs are rotating away including spi.err, elog and maintenance error log. Actually they rotated so fast and they just keep one day log. (means we can only trace what is happening up to yesterday, for spi.err and elog). This left no evidence on CMS what happened on the CM side. You need to consult with your team why someone manually merge the data. Is there any CM operation going on during Aug 13 maintenance window?

Please be aware this is not a system automatic function for merging the data for CMS and survivable CMS. It has to be done manually. So you need to check with the team why someone within your team perform this action around 14:28 Aug 13th.

Admin-Sync for HA CMS
and Survivable CMS

1) Schedule Admin-Sync
2) Un-Schedule Admin-Sync
3) Synchronize Administrative Data Now
4) Transfer & Restore a Day's Call Data, (pull) FROM Secondary HA CMS
5) Transfer & Restore a Day's Call Data, (push) TO Secondary HA CMS
6) Transfer & Restore Interval Call Data, (pull) FROM Secondary HA CMS
7) Transfer & Restore Interval Call Data, (push) TO Secondary HA CMS
8) Merge Login/Logout Records with Secondary (for a Day)
9) Display Admin-Sync Version
10) View Log
11) Recover Data from Survivable CMS's
0) Exit

We could not remove merge data, this is working by design.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy