CM does not send back ACK to UAS when calling SIP


Doc ID    SOLN275833
Version:    1.0
Status:    Published
Published date:    28 Sep 2015
Author:   
Andras Varga
 

Details

CM won't send an ACK back to UAS when CM calling SIP

CM: R016x.03.0.124.0

Call flow: H.323 IP Phone calls out via SIP trunk and via SBC.

List trace findings:

15:13:41.183 |--INVITE-->| (93) T:+called party F:+<caller party> U:+<called party>
15:13:41.190 |<--Trying--| (93) 100 Trying
15:13:42.010 |<--Ringing-| (93) 180 Ringing
15:13:49.018 |<--200 OK--| (93) 200 OK
15:13:49.510 |<--200 OK--| (93) 200 OK
15:13:50.515 |<--200 OK--| (93) 200 OK
15:13:52.522 |<--200 OK--| (93) 200 OK
15:13:56.525 |<--200 OK--| (93) 200 OK
15:14:00.530 |<--200 OK--| (93) 200 OK
15:14:02.836 |<----BYE---| (93) sip:<caller Party>@<IP address>
15:14:02.837 |--Call Do->| (93) 481 Call Does Not Exist (no local tag match)
15:16:41.188 |--CANCEL-->| (93) sip:<called party>@<IP address>
15:16:41.193 |<--Call/Tr-| (93) 481 Call/Transaction Does Not Exist
 
Debug & MST trace findings:

CM does not send ACK because the 180 ringing and the 200 OK messages have parser error. The debugs point to
# 20150923 151342010 12787547 capro 885  MED  cUASIPStack  decodeMessage
# 20150923 151342010 12787548 capro 885  MED  allow Parse failed early  Expected CR/LF to terminate header

Problem Clarification

CM does not send back ACK to UAS when calling SIP. The number is working, managed to call from cellphone. ACME SBC sends 200 OK.

Cause

One of the content of the ALLOW header was invalid.
Wrong ALLOW:

INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,REFER,SUBSCRIBER,NOTIFY,MESSAGE,INFO,PRACK,UPDATE

Fixed ALLOW:

INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,REFER,SUBSCRIBE,NOTIFY,MESSAGE,INFO,PRACK,UPDATE

Solution

The fix the wrong ALLOW header.


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